summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-12-03 16:10:41 +0000
committerHans de Graaff <graaff@gentoo.org>2010-12-03 16:10:41 +0000
commit110f9f18b5be18a7a2fffa95999cc66b7558a6fd (patch)
tree3de517bd0266a17ec845c07e0f065606de9f12a8 /dev-ruby/activemodel
parentVersion bump (diff)
downloadgentoo-2-110f9f18b5be18a7a2fffa95999cc66b7558a6fd.tar.gz
gentoo-2-110f9f18b5be18a7a2fffa95999cc66b7558a6fd.tar.bz2
gentoo-2-110f9f18b5be18a7a2fffa95999cc66b7558a6fd.zip
Initial import for Rails 3.0.3.
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activemodel')
-rw-r--r--dev-ruby/activemodel/ChangeLog10
-rw-r--r--dev-ruby/activemodel/activemodel-3.0.3.ebuild41
-rw-r--r--dev-ruby/activemodel/metadata.xml5
3 files changed, 56 insertions, 0 deletions
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
new file mode 100644
index 000000000000..893677605059
--- /dev/null
+++ b/dev-ruby/activemodel/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/activemodel
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.1 2010/12/03 16:10:41 graaff Exp $
+
+*activemodel-3.0.3 (03 Dec 2010)
+
+ 03 Dec 2010; Hans de Graaff <graaff@gentoo.org> +activemodel-3.0.3.ebuild,
+ +metadata.xml:
+ Initial import for Rails 3.0.3.
+
diff --git a/dev-ruby/activemodel/activemodel-3.0.3.ebuild b/dev-ruby/activemodel/activemodel-3.0.3.ebuild
new file mode 100644
index 000000000000..1a9e2b0a4dd4
--- /dev/null
+++ b/dev-ruby/activemodel/activemodel-3.0.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.0.3.ebuild,v 1.1 2010/12/03 16:10:41 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
+HOMEPAGE="http://github.com/rails/rails"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="mysql postgres sqlite3" #sqlite
+
+S="${WORKDIR}/rails-rails-*/activemodel"
+
+ruby_add_rdepend "
+ ~dev-ruby/activesupport-${PV}
+ >=dev-ruby/builder-2.1.2
+ >=dev-ruby/i18n-0.4.1:0.4"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/ruby-debug
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
+}
diff --git a/dev-ruby/activemodel/metadata.xml b/dev-ruby/activemodel/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/activemodel/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>