summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-05-12 19:03:08 +0000
committerHans de Graaff <graaff@gentoo.org>2014-05-12 19:03:08 +0000
commit84bd8aaf47fd7095a5f66ee1b4af54ef14363ebd (patch)
tree982f91ee2d90c9093fea64b15f15622151fe2588 /dev-ruby/activemodel
parentCleanup. (diff)
downloadgentoo-2-84bd8aaf47fd7095a5f66ee1b4af54ef14363ebd.tar.gz
gentoo-2-84bd8aaf47fd7095a5f66ee1b4af54ef14363ebd.tar.bz2
gentoo-2-84bd8aaf47fd7095a5f66ee1b4af54ef14363ebd.zip
Cleanup.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/activemodel')
-rw-r--r--dev-ruby/activemodel/ChangeLog7
-rw-r--r--dev-ruby/activemodel/activemodel-3.2.17.ebuild50
-rw-r--r--dev-ruby/activemodel/activemodel-4.0.3.ebuild46
-rw-r--r--dev-ruby/activemodel/activemodel-4.0.4.ebuild46
-rw-r--r--dev-ruby/activemodel/activemodel-4.1.0.ebuild44
5 files changed, 6 insertions, 187 deletions
diff --git a/dev-ruby/activemodel/ChangeLog b/dev-ruby/activemodel/ChangeLog
index f3b2f7786da8..1f9174fb74c5 100644
--- a/dev-ruby/activemodel/ChangeLog
+++ b/dev-ruby/activemodel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activemodel
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.78 2014/05/06 20:00:09 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/ChangeLog,v 1.79 2014/05/12 19:03:08 graaff Exp $
+
+ 12 May 2014; Hans de Graaff <graaff@gentoo.org> -activemodel-3.2.17.ebuild,
+ -activemodel-4.0.3.ebuild, -activemodel-4.0.4.ebuild,
+ -activemodel-4.1.0.ebuild:
+ Cleanup.
*activemodel-4.1.1 (06 May 2014)
diff --git a/dev-ruby/activemodel/activemodel-3.2.17.ebuild b/dev-ruby/activemodel/activemodel-3.2.17.ebuild
deleted file mode 100644
index 92c705b2793e..000000000000
--- a/dev-ruby/activemodel/activemodel-3.2.17.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-3.2.17.ebuild,v 1.2 2014/05/04 11:30:08 mrueg Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
-HOMEPAGE="http://github.com/rails/rails"
-SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/activesupport-${PV}
- >=dev-ruby/builder-3.0.0:3
- >=dev-ruby/bcrypt-ruby-3.0.0"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/test-unit:2
- >=dev-ruby/mocha-0.13.0:0.13
- )"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
- rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
- sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
-
- # Make sure we use the test-unit gem since ruby18 does not provide
- # all the test-unit features needed.
- sed -i -e '1igem "test-unit"' test/cases/helper.rb || die
-
- # Fix bcrypt dependency since bcrypt uses semantic versioning.
- sed -i -e '/bcrypt-ruby/ s/3.0.0/3.0/' lib/active_model/secure_password.rb || die
-}
diff --git a/dev-ruby/activemodel/activemodel-4.0.3.ebuild b/dev-ruby/activemodel/activemodel-4.0.3.ebuild
deleted file mode 100644
index 3986e68a10b7..000000000000
--- a/dev-ruby/activemodel/activemodel-4.0.3.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-4.0.3.ebuild,v 1.2 2014/03/11 20:07:58 johu Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
-HOMEPAGE="http://github.com/rails/rails"
-SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/activesupport-${PV}
- >=dev-ruby/builder-3.1.0:3.1
- >=dev-ruby/bcrypt-ruby-3.0.0"
-
-ruby_add_bdepend "
- test? (
- >=dev-ruby/railties-4.0.0
- dev-ruby/test-unit:2
- >=dev-ruby/mocha-0.13.0:0.13
- )"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
- sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
-
- # Fix bcrypt dependency since bcrypt uses semantic versioning.
- sed -i -e '/bcrypt-ruby/ s/3.0.0/3.0/' lib/active_model/secure_password.rb || die
-}
diff --git a/dev-ruby/activemodel/activemodel-4.0.4.ebuild b/dev-ruby/activemodel/activemodel-4.0.4.ebuild
deleted file mode 100644
index 2d97fa760b30..000000000000
--- a/dev-ruby/activemodel/activemodel-4.0.4.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-4.0.4.ebuild,v 1.2 2014/04/21 06:16:34 graaff Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20 ruby21"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
-HOMEPAGE="http://github.com/rails/rails"
-SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/activesupport-${PV}
- >=dev-ruby/builder-3.1.0:3.1
- >=dev-ruby/bcrypt-ruby-3.1.7"
-
-ruby_add_bdepend "
- test? (
- >=dev-ruby/railties-4.0.0
- dev-ruby/test-unit:2
- >=dev-ruby/mocha-0.13.0:0.13
- )"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
- sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
-
- # Fix bcrypt dependency since bcrypt uses semantic versioning.
- sed -i -e '/bcrypt-ruby/ s/3.0.0/3.0/' lib/active_model/secure_password.rb || die
-}
diff --git a/dev-ruby/activemodel/activemodel-4.1.0.ebuild b/dev-ruby/activemodel/activemodel-4.1.0.ebuild
deleted file mode 100644
index 43756fc235e1..000000000000
--- a/dev-ruby/activemodel/activemodel-4.1.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activemodel/activemodel-4.1.0.ebuild,v 1.1 2014/04/26 15:09:14 graaff Exp $
-
-EAPI=5
-
-USE_RUBY="ruby19 ruby20 ruby21"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_DOCDIR=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
-
-RUBY_FAKEGEM_GEMSPEC="activemodel.gemspec"
-
-inherit ruby-fakegem versionator
-
-DESCRIPTION="A toolkit for building modeling frameworks like Active Record and Active Resource."
-HOMEPAGE="http://github.com/rails/rails"
-SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~amd64 ~arm"
-IUSE=""
-
-RUBY_S="rails-${PV}/${PN}"
-
-ruby_add_rdepend "
- ~dev-ruby/activesupport-${PV}
- >=dev-ruby/builder-3.1.0:3.1
-"
-
-ruby_add_bdepend "
- test? (
- >=dev-ruby/railties-4.0.0
- dev-ruby/test-unit:2
- >=dev-ruby/mocha-0.14.0:0.14
- >=dev-ruby/bcrypt-ruby-3.1.7
- )"
-
-all_ruby_prepare() {
- # Set test environment to our hand.
- sed -i -e '/load_paths/d' test/cases/helper.rb || die "Unable to remove load paths"
-}