summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-06-09 17:07:41 +0000
committerHans de Graaff <graaff@gentoo.org>2011-06-09 17:07:41 +0000
commit765a7c89c3047c923b01004202c08f10212506d5 (patch)
tree049fce229a89b15f81dce8bfb5f6c724eb84dea5 /dev-ruby/activeresource
parentVersion bump. (diff)
downloadgentoo-2-765a7c89c3047c923b01004202c08f10212506d5.tar.gz
gentoo-2-765a7c89c3047c923b01004202c08f10212506d5.tar.bz2
gentoo-2-765a7c89c3047c923b01004202c08f10212506d5.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/activeresource')
-rw-r--r--dev-ruby/activeresource/ChangeLog8
-rw-r--r--dev-ruby/activeresource/activeresource-2.3.12.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index ff6e0cec54ac..13bb516fb65a 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.81 2011/06/09 15:23:05 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.82 2011/06/09 17:07:41 graaff Exp $
+
+*activeresource-2.3.12 (09 Jun 2011)
+
+ 09 Jun 2011; Hans de Graaff <graaff@gentoo.org>
+ +activeresource-2.3.12.ebuild:
+ Version bump.
09 Jun 2011; Hans de Graaff <graaff@gentoo.org> -activeresource-2.2.3.ebuild:
Remove old version.
diff --git a/dev-ruby/activeresource/activeresource-2.3.12.ebuild b/dev-ruby/activeresource/activeresource-2.3.12.ebuild
new file mode 100644
index 000000000000..0d9ed1624146
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-2.3.12.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-2.3.12.ebuild,v 1.1 2011/06/09 17:07:41 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 -x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}"
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}/${PN}-2.3.10-rails3.patch"
+
+ # Custom template not found in package
+ sed -i -e '/horo/d' Rakefile || die
+}