summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-07-03 05:38:23 +0000
committerHans de Graaff <graaff@gentoo.org>2014-07-03 05:38:23 +0000
commitb4181d3476677bdb8b8ca2c024f3d219820d6a39 (patch)
tree4c76ad75407b09268a64a2631536f375a5eedede /dev-ruby/activeresource
parentVersion bump to Rails 3.2.19 for security bug 516084. (diff)
downloadgentoo-2-b4181d3476677bdb8b8ca2c024f3d219820d6a39.tar.gz
gentoo-2-b4181d3476677bdb8b8ca2c024f3d219820d6a39.tar.bz2
gentoo-2-b4181d3476677bdb8b8ca2c024f3d219820d6a39.zip
Version bump to Rails 3.2.19 for security bug 516084.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/activeresource')
-rw-r--r--dev-ruby/activeresource/ChangeLog8
-rw-r--r--dev-ruby/activeresource/activeresource-3.2.19.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-ruby/activeresource/ChangeLog b/dev-ruby/activeresource/ChangeLog
index 32a285345fb2..f38e50968927 100644
--- a/dev-ruby/activeresource/ChangeLog
+++ b/dev-ruby/activeresource/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/activeresource
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.172 2014/05/12 19:02:50 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/ChangeLog,v 1.173 2014/07/03 05:38:23 graaff Exp $
+
+*activeresource-3.2.19 (03 Jul 2014)
+
+ 03 Jul 2014; Hans de Graaff <graaff@gentoo.org>
+ +activeresource-3.2.19.ebuild:
+ Version bump to Rails 3.2.19 for security bug 516084.
12 May 2014; Hans de Graaff <graaff@gentoo.org>
-activeresource-3.2.17.ebuild:
diff --git a/dev-ruby/activeresource/activeresource-3.2.19.ebuild b/dev-ruby/activeresource/activeresource-3.2.19.ebuild
new file mode 100644
index 000000000000..6aecbbb2d469
--- /dev/null
+++ b/dev-ruby/activeresource/activeresource-3.2.19.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activeresource/activeresource-3.2.19.ebuild,v 1.1 2014/07/03 05:38:23 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activeresource.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Think Active Record for web resources.."
+HOMEPAGE="http://rubyforge.org/projects/activeresource/"
+SRC_URI="http://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_S="rails-${PV}/${PN}"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ dev-ruby/builder:3"
+ruby_add_bdepend "
+ test? (
+ dev-ruby/test-unit:2
+ >=dev-ruby/mocha-0.13.0:0.13
+ )"
+
+all_ruby_prepare() {
+ # Set test environment to our hand.
+ rm "${S}/../Gemfile" || die "Unable to remove Gemfile"
+ sed -i -e '/load_paths/d' test/abstract_unit.rb || die "Unable to remove load paths"
+
+ # Make sure we use the test-unit gem since ruby18 does not provide
+ # all the test-unit features needed.
+ sed -i -e '1igem "test-unit"' test/abstract_unit.rb || die
+}