summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-02-11 21:21:41 +0000
committerHans de Graaff <graaff@gentoo.org>2013-02-11 21:21:41 +0000
commitae53fbb45a84c398805ebd68065eb41e2c76c54f (patch)
tree5ea26b706f1a7b0200112e0acab59f7e94378b1e /dev-ruby/activesupport
parentVersion bump, wrt bug #358461 - EAPI 5, port to distutils-r1 eclass, utilize ... (diff)
downloadgentoo-2-ae53fbb45a84c398805ebd68065eb41e2c76c54f.tar.gz
gentoo-2-ae53fbb45a84c398805ebd68065eb41e2c76c54f.tar.bz2
gentoo-2-ae53fbb45a84c398805ebd68065eb41e2c76c54f.zip
Version bump for security bug 456840.
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/activesupport')
-rw-r--r--dev-ruby/activesupport/ChangeLog7
-rw-r--r--dev-ruby/activesupport/activesupport-2.3.17.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-ruby/activesupport/ChangeLog b/dev-ruby/activesupport/ChangeLog
index 4c464b5dda3f..c28f4ee7fbc0 100644
--- a/dev-ruby/activesupport/ChangeLog
+++ b/dev-ruby/activesupport/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activesupport
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.214 2013/02/11 20:46:29 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/ChangeLog,v 1.215 2013/02/11 21:21:41 graaff Exp $
+
+*activesupport-2.3.17 (11 Feb 2013)
+
+ 11 Feb 2013; Hans de Graaff <graaff@gentoo.org> +activesupport-2.3.17.ebuild:
+ Version bump for security bug 456840.
*activesupport-3.1.11 (11 Feb 2013)
diff --git a/dev-ruby/activesupport/activesupport-2.3.17.ebuild b/dev-ruby/activesupport/activesupport-2.3.17.ebuild
new file mode 100644
index 000000000000..03e591a3f6c8
--- /dev/null
+++ b/dev-ruby/activesupport/activesupport-2.3.17.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activesupport/activesupport-2.3.17.ebuild,v 1.1 2013/02/11 21:21:41 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility Classes and Extension to the Standard Library"
+HOMEPAGE="http://rubyforge.org/projects/activesupport/"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/builder-2.1.2:0 >=dev-ruby/tzinfo-0.3.16 >=dev-ruby/i18n-0.4.1:0.4"
+
+all_ruby_prepare() {
+ # Remove the bundled packages!
+ rm -r lib/active_support/vendor/{tzinfo,builder,i18n}-* \
+ || die "failed to remove vendor packages"
+
+ # This patch removes the fallback to local vendorized gems, as well
+ # as fixing the dependencies for i18n to use the correct slot. It
+ # also edits the metadata file so that the dependencies are added to
+ # the specification, which is required for bundler to pick them up
+ # (which in turn is required by radiant 1.0.0rc3 to
+ # work). Furthermore remove the references to the vendorized copies
+ # from the specification, to be safe.
+ mv ../metadata . || die
+ epatch "${FILESDIR}"/${PN}-2.3.16-unvendorize.patch
+ mv metadata .. || die
+ sed -i -e '/\/vendor\//d' ../metadata
+
+ # don't support older mocha versions as the optional codepath
+ # breaks JRuby
+ epatch "${FILESDIR}"/${PN}-2.3.5-mocha-0.9.5.patch
+}