summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-04 19:02:33 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-04 19:02:33 +0000
commita0986a0ce8e6745f7d911c2ef89e67db88339041 (patch)
treef582ed12822b7dc3bd11387b26cc59d2a68fc68f /dev-ruby/allison
parentAdd ruby20 target. (diff)
downloadgentoo-2-a0986a0ce8e6745f7d911c2ef89e67db88339041.tar.gz
gentoo-2-a0986a0ce8e6745f7d911c2ef89e67db88339041.tar.bz2
gentoo-2-a0986a0ce8e6745f7d911c2ef89e67db88339041.zip
Add ruby20 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/allison')
-rw-r--r--dev-ruby/allison/ChangeLog9
-rw-r--r--dev-ruby/allison/allison-2.0.3-r2.ebuild29
2 files changed, 36 insertions, 2 deletions
diff --git a/dev-ruby/allison/ChangeLog b/dev-ruby/allison/ChangeLog
index 7b93b60953ee..a2b180abce55 100644
--- a/dev-ruby/allison/ChangeLog
+++ b/dev-ruby/allison/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/allison
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/allison/ChangeLog,v 1.23 2012/12/16 18:03:20 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/allison/ChangeLog,v 1.24 2013/10/04 19:02:33 mrueg Exp $
+
+*allison-2.0.3-r2 (04 Oct 2013)
+
+ 04 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +allison-2.0.3-r2.ebuild:
+ Add ruby20 target.
16 Dec 2012; Raúl Porcel <armin76@gentoo.org> allison-2.0.3-r1.ebuild:
alpha/ia64/sparc stable wrt #444458
diff --git a/dev-ruby/allison/allison-2.0.3-r2.ebuild b/dev-ruby/allison/allison-2.0.3-r2.ebuild
new file mode 100644
index 000000000000..cf5cbb4ea131
--- /dev/null
+++ b/dev-ruby/allison/allison-2.0.3-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/allison/allison-2.0.3-r2.ebuild,v 1.1 2013/10/04 19:02:33 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README"
+RUBY_FAKEGEM_EXTRAINSTALL="cache"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A modern, pretty RDoc template."
+HOMEPAGE="http://fauna.github.com/fauna/allison/files/README.html"
+
+LICENSE="AFL-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-solaris"
+IUSE=""
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r contrib
+}