summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-04-27 11:22:40 +0000
committerHans de Graaff <graaff@gentoo.org>2013-04-27 11:22:40 +0000
commitb90c6944b64cf8b3ad1acfb8193b658e4da6e41d (patch)
tree146b6c7506192a428ee757c826e5b371e70046df /dev-ruby/amq-protocol
parentAdd a useful site that explains more about microcodes. (diff)
downloadgentoo-2-b90c6944b64cf8b3ad1acfb8193b658e4da6e41d.tar.gz
gentoo-2-b90c6944b64cf8b3ad1acfb8193b658e4da6e41d.tar.bz2
gentoo-2-b90c6944b64cf8b3ad1acfb8193b658e4da6e41d.zip
Version bump.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/amq-protocol')
-rw-r--r--dev-ruby/amq-protocol/ChangeLog7
-rw-r--r--dev-ruby/amq-protocol/amq-protocol-1.3.0.ebuild26
2 files changed, 32 insertions, 1 deletions
diff --git a/dev-ruby/amq-protocol/ChangeLog b/dev-ruby/amq-protocol/ChangeLog
index 60216614df48..841ad2aa7e5d 100644
--- a/dev-ruby/amq-protocol/ChangeLog
+++ b/dev-ruby/amq-protocol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/amq-protocol
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amq-protocol/ChangeLog,v 1.8 2013/02/23 08:48:59 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amq-protocol/ChangeLog,v 1.9 2013/04/27 11:22:40 graaff Exp $
+
+*amq-protocol-1.3.0 (27 Apr 2013)
+
+ 27 Apr 2013; Hans de Graaff <graaff@gentoo.org> +amq-protocol-1.3.0.ebuild:
+ Version bump.
*amq-protocol-1.2.0 (23 Feb 2013)
diff --git a/dev-ruby/amq-protocol/amq-protocol-1.3.0.ebuild b/dev-ruby/amq-protocol/amq-protocol-1.3.0.ebuild
new file mode 100644
index 000000000000..ffb3615b87bd
--- /dev/null
+++ b/dev-ruby/amq-protocol/amq-protocol-1.3.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amq-protocol/amq-protocol-1.3.0.ebuild,v 1.1 2013/04/27 11:22:40 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An AMQP 0.9.1 serialization library for Ruby."
+HOMEPAGE="http://github.com/ruby-amqp/amq-protocol"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/bundler/ s:^:#:' -e '/effin_utf8/ s:^:#:' spec/spec_helper.rb || die
+}