summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-03-19 14:01:34 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-03-19 14:01:34 +0000
commitef5f700fe0ed6ba69c63fbd72d5a19d8c043e7c2 (patch)
tree30a177a0248054608d2c18aecd3e965fa22a920e /dev-ruby/bcrypt-ruby
parentTemporarly block non-live FFMPEG versions in live VLC with USE flag vdpau; fi... (diff)
downloadgentoo-2-ef5f700fe0ed6ba69c63fbd72d5a19d8c043e7c2.tar.gz
gentoo-2-ef5f700fe0ed6ba69c63fbd72d5a19d8c043e7c2.tar.bz2
gentoo-2-ef5f700fe0ed6ba69c63fbd72d5a19d8c043e7c2.zip
Cleanup old.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/bcrypt-ruby')
-rw-r--r--dev-ruby/bcrypt-ruby/ChangeLog6
-rw-r--r--dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.2-r1.ebuild36
-rw-r--r--dev-ruby/bcrypt-ruby/files/bcrypt-ruby-3.0.1-undefined-symbols.patch42
3 files changed, 5 insertions, 79 deletions
diff --git a/dev-ruby/bcrypt-ruby/ChangeLog b/dev-ruby/bcrypt-ruby/ChangeLog
index d5419262ce00..e56686a2e03e 100644
--- a/dev-ruby/bcrypt-ruby/ChangeLog
+++ b/dev-ruby/bcrypt-ruby/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/bcrypt-ruby
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bcrypt-ruby/ChangeLog,v 1.19 2014/03/06 08:00:22 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bcrypt-ruby/ChangeLog,v 1.20 2014/03/19 14:01:33 mrueg Exp $
+
+ 19 Mar 2014; Manuel Rüger <mrueg@gentoo.org> -bcrypt-ruby-3.1.2-r1.ebuild,
+ -files/bcrypt-ruby-3.0.1-undefined-symbols.patch:
+ Cleanup old.
*bcrypt-ruby-3.1.7 (06 Mar 2014)
diff --git a/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.2-r1.ebuild b/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.2-r1.ebuild
deleted file mode 100644
index 9478934316f7..000000000000
--- a/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.2-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bcrypt-ruby/bcrypt-ruby-3.1.2-r1.ebuild,v 1.1 2013/11/05 00:43:13 mrueg Exp $
-
-EAPI=5
-
-USE_RUBY="ruby18 ruby19 ruby20"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.md"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="An easy way to keep your users' passwords secure."
-HOMEPAGE="http://bcrypt-ruby.rubyforge.org/"
-LICENSE="MIT"
-
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-all_ruby_prepare() {
- rm Gemfile || die
- sed -i -e '/git ls-files/d' bcrypt-ruby.gemspec || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/mri extconf.rb || die
-}
-
-each_ruby_compile() {
- emake -Cext/mri V=1
- cp ext/mri/*$(get_modname) lib/ || die
-}
diff --git a/dev-ruby/bcrypt-ruby/files/bcrypt-ruby-3.0.1-undefined-symbols.patch b/dev-ruby/bcrypt-ruby/files/bcrypt-ruby-3.0.1-undefined-symbols.patch
deleted file mode 100644
index 37abf2624c02..000000000000
--- a/dev-ruby/bcrypt-ruby/files/bcrypt-ruby-3.0.1-undefined-symbols.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-commit 94f8d0ae95ed773cb9e31a71e4046d3b97e11d70
-Author: Aman Gupta <aman@tmm1.net>
-Date: Sat Mar 30 19:52:19 2013 -0700
-
- remove last of TBR code (fixes #46)
-
-diff --git a/ext/mri/bcrypt_ext.c b/ext/mri/bcrypt_ext.c
-index cce35df..13f5e4e 100644
---- a/ext/mri/bcrypt_ext.c
-+++ b/ext/mri/bcrypt_ext.c
-@@ -4,31 +4,6 @@
- static VALUE mBCrypt;
- static VALUE cBCryptEngine;
-
--#ifdef RUBY_VM
--# define RUBY_1_9
--#endif
--
--#ifdef RUBY_1_9
--
--/* When on Ruby 1.9+, we will want to unlock the GIL while performing
-- * expensive calculations, for greater concurrency. Do not do this for
-- * cheap calculations because locking/unlocking the GIL incurs some overhead as well.
-- */
--#define GIL_UNLOCK_COST_THRESHOLD 9
--
--typedef struct {
-- char *output;
-- const char *key;
-- const char *salt;
--} BCryptArguments;
--
--static VALUE bcrypt_wrapper(void *_args) {
-- BCryptArguments *args = (BCryptArguments *)_args;
-- return (VALUE)ruby_bcrypt(args->output, args->key, args->salt);
--}
--
--#endif /* RUBY_1_9 */
--
- /* Given a logarithmic cost parameter, generates a salt for use with +bc_crypt+.
- */
- static VALUE bc_salt(VALUE self, VALUE prefix, VALUE count, VALUE input) {