summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-05-26 05:21:43 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-05-26 05:21:43 +0000
commit515b372b345ccb625df3fd8ba7ff27ba1bc2bd45 (patch)
tree85089d695c7594bc4a05d2d0cdba96e8a171c6fb /dev-ruby/bson
parentRemove ruby18 target. (diff)
downloadgentoo-2-515b372b345ccb625df3fd8ba7ff27ba1bc2bd45.tar.gz
gentoo-2-515b372b345ccb625df3fd8ba7ff27ba1bc2bd45.tar.bz2
gentoo-2-515b372b345ccb625df3fd8ba7ff27ba1bc2bd45.zip
Remove ruby18 target.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/bson')
-rw-r--r--dev-ruby/bson/ChangeLog9
-rw-r--r--dev-ruby/bson/bson-1.6.2-r1.ebuild12
-rw-r--r--dev-ruby/bson/bson-2.0.0.ebuild10
3 files changed, 17 insertions, 14 deletions
diff --git a/dev-ruby/bson/ChangeLog b/dev-ruby/bson/ChangeLog
index f06d57276b24..c142c5d6bbfd 100644
--- a/dev-ruby/bson/ChangeLog
+++ b/dev-ruby/bson/ChangeLog
@@ -1,10 +1,13 @@
# ChangeLog for dev-ruby/bson
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bson/ChangeLog,v 1.9 2013/12/25 07:40:41 graaff Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bson/ChangeLog,v 1.10 2014/05/26 05:21:43 mrueg Exp $
+
+ 26 May 2014; Manuel Rüger <mrueg@gentoo.org> bson-1.6.2-r1.ebuild,
+ bson-2.0.0.ebuild:
+ Remove ruby18 target.
*bson-2.0.0 (25 Dec 2013)
25 Dec 2013; Hans de Graaff <graaff@gentoo.org> +bson-2.0.0.ebuild:
Version bump. Upstream now releases one gem with the compiled extension
included.
-
diff --git a/dev-ruby/bson/bson-1.6.2-r1.ebuild b/dev-ruby/bson/bson-1.6.2-r1.ebuild
index 2201a31aa0ee..e35d2ffc50c3 100644
--- a/dev-ruby/bson/bson-1.6.2-r1.ebuild
+++ b/dev-ruby/bson/bson-1.6.2-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bson/bson-1.6.2-r1.ebuild,v 1.1 2013/11/17 20:53:42 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bson/bson-1.6.2-r1.ebuild,v 1.2 2014/05/26 05:21:43 mrueg Exp $
EAPI=5
# jruby → support needs to be written properly
-USE_RUBY="ruby18 ruby19 ruby20"
+USE_RUBY="ruby19 ruby20"
RUBY_FAKEGEM_TASK_DOC="moot" # we do it manually, but still declare it
RUBY_FAKEGEM_DOCDIR="html"
@@ -43,7 +43,7 @@ all_ruby_prepare() {
each_ruby_configure() {
case ${RUBY} in
- */ruby18|*/ruby19|*/ruby20)
+ */ruby19|*/ruby20)
${RUBY} -C ext/cbson extconf.rb || die "extconf.rb failed"
;;
*/jruby)
@@ -54,7 +54,7 @@ each_ruby_configure() {
each_ruby_compile() {
case ${RUBY} in
- */ruby18|*/ruby19|*/ruby20)
+ */ruby19|*/ruby20)
emake -C ext/cbson V=1 CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
mkdir -p lib/bson_ext
cp ext/cbson/*$(get_modname) lib/bson_ext || die
@@ -75,7 +75,7 @@ all_ruby_compile() {
each_ruby_test() {
case ${RUBY} in
- */ruby18|*/ruby19|*/ruby20)
+ */ruby19|*/ruby20)
C_EXT=true ${RUBY} -S rake test:bson || die "tests failed"
;;
esac
diff --git a/dev-ruby/bson/bson-2.0.0.ebuild b/dev-ruby/bson/bson-2.0.0.ebuild
index 41a4d9689279..bdff4a5375a8 100644
--- a/dev-ruby/bson/bson-2.0.0.ebuild
+++ b/dev-ruby/bson/bson-2.0.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bson/bson-2.0.0.ebuild,v 1.1 2013/12/25 07:40:41 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bson/bson-2.0.0.ebuild,v 1.2 2014/05/26 05:21:43 mrueg Exp $
EAPI=5
# jruby → support needs to be written properly
-USE_RUBY="ruby18 ruby19 ruby20"
+USE_RUBY="ruby19 ruby20"
RUBY_FAKEGEM_RECIPE_TEST="rspec"
@@ -47,7 +47,7 @@ all_ruby_prepare() {
each_ruby_configure() {
case ${RUBY} in
- */ruby18|*/ruby19|*/ruby20)
+ */ruby19|*/ruby20)
${RUBY} -C ext/bson extconf.rb || die "extconf.rb failed"
;;
*/jruby)
@@ -58,7 +58,7 @@ each_ruby_configure() {
each_ruby_compile() {
case ${RUBY} in
- */ruby18|*/ruby19|*/ruby20)
+ */ruby19|*/ruby20)
emake -C ext/bson V=1 CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
cp ext/bson/*$(get_modname) lib/ || die
;;