summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-09-10 05:47:41 +0000
committerHans de Graaff <graaff@gentoo.org>2013-09-10 05:47:41 +0000
commit318c806185900d77b5c554fa91dd4e0d2be831ae (patch)
tree758bdaa9fe8b1625b14399013fad1d19b2941c4f /dev-ruby/bundler
parentVersion bump. (diff)
downloadgentoo-2-318c806185900d77b5c554fa91dd4e0d2be831ae.tar.gz
gentoo-2-318c806185900d77b5c554fa91dd4e0d2be831ae.tar.bz2
gentoo-2-318c806185900d77b5c554fa91dd4e0d2be831ae.zip
Cleanup.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/bundler')
-rw-r--r--dev-ruby/bundler/ChangeLog6
-rw-r--r--dev-ruby/bundler/bundler-1.0.22.ebuild56
-rw-r--r--dev-ruby/bundler/bundler-1.1.5.ebuild46
3 files changed, 5 insertions, 103 deletions
diff --git a/dev-ruby/bundler/ChangeLog b/dev-ruby/bundler/ChangeLog
index 1071dc37eda4..67cd0ad411a2 100644
--- a/dev-ruby/bundler/ChangeLog
+++ b/dev-ruby/bundler/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/bundler
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/ChangeLog,v 1.53 2013/05/28 13:12:55 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/ChangeLog,v 1.54 2013/09/10 05:47:41 graaff Exp $
+
+ 10 Sep 2013; Hans de Graaff <graaff@gentoo.org> -bundler-1.0.22.ebuild,
+ -bundler-1.1.5.ebuild:
+ Cleanup.
28 May 2013; Jeroen Roovers <jer@gentoo.org> bundler-1.3.5.ebuild:
Marked ~hppa (bug #471306).
diff --git a/dev-ruby/bundler/bundler-1.0.22.ebuild b/dev-ruby/bundler/bundler-1.0.22.ebuild
deleted file mode 100644
index 748a37722803..000000000000
--- a/dev-ruby/bundler/bundler-1.0.22.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/bundler-1.0.22.ebuild,v 1.6 2013/01/16 00:28:32 zerochaos Exp $
-
-EAPI=2
-
-# jruby → needs to be tested because jruby-1.5.1 fails in multiple
-# ways unrelated to this package.
-USE_RUBY="ruby18 ruby19 ree18"
-
-RUBY_FAKEGEM_TASK_TEST="spec"
-
-# No documentation task
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md ISSUES.md UPGRADING.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="An easy way to vendor gem dependencies"
-HOMEPAGE="http://github.com/carlhuda/bundler"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend virtual/rubygems
-
-ruby_add_bdepend "test? ( app-text/ronn dev-ruby/rspec:2 )"
-
-RDEPEND="${RDEPEND}
- dev-vcs/git"
-DEPEND="${DEPEND}
- test? ( dev-vcs/git )"
-
-all_ruby_prepare() {
- # Reported upstream: http://github.com/carlhuda/bundler/issues/issue/738
- sed -i -e '726s/should/should_not/' spec/runtime/setup_spec.rb || die
-
- # Fails randomly and no clear cause can be found. Might be related
- # to bug 346357. This was broken in previous releases without a
- # failing spec, so patch out this spec for now since it is not a
- # regression.
- sed -i -e '49,54d' spec/install/deploy_spec.rb || die
-}
-
-each_ruby_prepare() {
- case ${RUBY} in
- *ruby19)
- # Account for different wording in ruby 1.9.3.
- sed -i -e 's/no such file to load/cannot load such file/' spec/runtime/require_spec.rb spec/install/gems/groups_spec.rb || die
- ;;
- *)
- ;;
- esac
-}
diff --git a/dev-ruby/bundler/bundler-1.1.5.ebuild b/dev-ruby/bundler/bundler-1.1.5.ebuild
deleted file mode 100644
index 7101d427d558..000000000000
--- a/dev-ruby/bundler/bundler-1.1.5.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/bundler/bundler-1.1.5.ebuild,v 1.3 2013/01/16 00:28:32 zerochaos Exp $
-
-EAPI=4
-
-# jruby → needs to be tested because jruby-1.5.1 fails in multiple
-# ways unrelated to this package.
-USE_RUBY="ruby18 ruby19 ree18"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-
-# No documentation task
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md ISSUES.md UPGRADING.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="An easy way to vendor gem dependencies"
-HOMEPAGE="http://github.com/carlhuda/bundler"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend virtual/rubygems
-
-ruby_add_bdepend "test? ( app-text/ronn )"
-
-RDEPEND+=" dev-vcs/git"
-DEPEND+=" test? ( dev-vcs/git )"
-
-RUBY_PATCHES=( "${P}-nouserpriv.patch" )
-
-all_ruby_prepare() {
- # Bundler only supports running the specs from git:
- # http://github.com/carlhuda/bundler/issues/issue/738
- sed -i -e '751s/should/should_not/' spec/runtime/setup_spec.rb || die
-
- # Fails randomly and no clear cause can be found. Might be related
- # to bug 346357. This was broken in previous releases without a
- # failing spec, so patch out this spec for now since it is not a
- # regression.
- sed -i -e '/works when you bundle exec bundle/,/^ end/ s:^:#:' spec/install/deploy_spec.rb || die
-}