summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-12-16 08:43:39 +0000
committerHans de Graaff <graaff@gentoo.org>2012-12-16 08:43:39 +0000
commita5b0717b212fb73aa8ddd3ba0d9e7e52718f4e9b (patch)
treed97a97219b9b62a928b86c12d7fe6e3c13b1d618 /dev-ruby/capistrano
parentVersion bump for gnome-3.6 with various UI fixes and libarchive support. Drop... (diff)
downloadgentoo-2-a5b0717b212fb73aa8ddd3ba0d9e7e52718f4e9b.tar.gz
gentoo-2-a5b0717b212fb73aa8ddd3ba0d9e7e52718f4e9b.tar.bz2
gentoo-2-a5b0717b212fb73aa8ddd3ba0d9e7e52718f4e9b.zip
Version bump. Fixes bug 447200.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/capistrano')
-rw-r--r--dev-ruby/capistrano/ChangeLog7
-rw-r--r--dev-ruby/capistrano/capistrano-2.13.5.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-ruby/capistrano/ChangeLog b/dev-ruby/capistrano/ChangeLog
index 8752d83b03e6..3eb585c7fe90 100644
--- a/dev-ruby/capistrano/ChangeLog
+++ b/dev-ruby/capistrano/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/capistrano
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/ChangeLog,v 1.81 2012/10/04 06:06:34 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/ChangeLog,v 1.82 2012/12/16 08:43:39 graaff Exp $
+
+*capistrano-2.13.5 (16 Dec 2012)
+
+ 16 Dec 2012; Hans de Graaff <graaff@gentoo.org> +capistrano-2.13.5.ebuild:
+ Version bump. Fixes bug 447200.
*capistrano-2.13.4 (04 Oct 2012)
diff --git a/dev-ruby/capistrano/capistrano-2.13.5.ebuild b/dev-ruby/capistrano/capistrano-2.13.5.ebuild
new file mode 100644
index 000000000000..de416e5cabf0
--- /dev/null
+++ b/dev-ruby/capistrano/capistrano-2.13.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/capistrano/capistrano-2.13.5.ebuild,v 1.1 2012/12/16 08:43:39 graaff Exp $
+
+EAPI=5
+# ruby19 → pending on net/sftp
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.mdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A distributed application deployment system"
+HOMEPAGE="http://capify.org/"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/net-ssh-2.0.14
+ >=dev-ruby/net-sftp-2.0.2
+ >=dev-ruby/net-scp-1.0.2
+ >=dev-ruby/net-ssh-gateway-1.1.0
+ >=dev-ruby/highline-1.2.7"
+ruby_add_bdepend "
+ test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile test/utils.rb || die
+# sed -i -e '/ruby-debug/ s:^:#:' test/utils.rb || die
+
+ # Avoid copy strategy tests since these fail in some cases due to
+ # complicated (aka unknown) interactions with other parts of the
+ # test suite.
+ rm test/deploy/strategy/copy_test.rb || die
+}