summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-09-07 11:34:34 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-09-07 11:34:34 +0000
commite65e9392e262d9068b3bdc3058e350875a311ca3 (patch)
tree782e74f2c705ebfa27b5a3a7a77c98e62514d78b /dev-ruby/celluloid
parentVersion bump. (diff)
downloadgentoo-2-e65e9392e262d9068b3bdc3058e350875a311ca3.tar.gz
gentoo-2-e65e9392e262d9068b3bdc3058e350875a311ca3.tar.bz2
gentoo-2-e65e9392e262d9068b3bdc3058e350875a311ca3.zip
Version bump.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/celluloid')
-rw-r--r--dev-ruby/celluloid/ChangeLog7
-rw-r--r--dev-ruby/celluloid/celluloid-0.15.1.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-ruby/celluloid/ChangeLog b/dev-ruby/celluloid/ChangeLog
index 9901a96bc767..42d3d9b8ab7b 100644
--- a/dev-ruby/celluloid/ChangeLog
+++ b/dev-ruby/celluloid/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/celluloid
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/celluloid/ChangeLog,v 1.3 2013/07/13 06:04:51 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/celluloid/ChangeLog,v 1.4 2013/09/07 11:34:34 mrueg Exp $
+
+*celluloid-0.15.1 (07 Sep 2013)
+
+ 07 Sep 2013; Manuel Rüger <mrueg@gentoo.org> +celluloid-0.15.1.ebuild:
+ Version bump.
*celluloid-0.14.1 (13 Jul 2013)
diff --git a/dev-ruby/celluloid/celluloid-0.15.1.ebuild b/dev-ruby/celluloid/celluloid-0.15.1.ebuild
new file mode 100644
index 000000000000..744e4444705a
--- /dev/null
+++ b/dev-ruby/celluloid/celluloid-0.15.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/celluloid/celluloid-0.15.1.ebuild,v 1.1 2013/09/07 11:34:34 mrueg Exp $
+
+EAPI=5
+# rbx or jruby recommended, but only in 1.9 mode.
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Celluloid provides a simple and natural way to build fault-tolerant concurrent programs in Ruby"
+HOMEPAGE="https://github.com/celluloid/celluloid"
+SRC_URI="https://github.com/celluloid/celluloid/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+
+ruby_add_rdepend ">=dev-ruby/timers-1.0.0"
+
+all_ruby_prepare() {
+ rm Gemfile .rspec || die
+
+ sed -i -e '/coveralls/I s:^:#:' spec/spec_helper.rb || die
+}