summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-10-24 14:51:47 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-10-24 14:51:47 +0000
commit881e96852f9722e039c78ee1cce630a6cb033bf5 (patch)
tree54a510a5aedc471eca0a60a9b9654c6735eacb37 /dev-ruby/configliere/configliere-0.4.22.ebuild
parentVersion bump. (diff)
downloadgentoo-2-881e96852f9722e039c78ee1cce630a6cb033bf5.tar.gz
gentoo-2-881e96852f9722e039c78ee1cce630a6cb033bf5.tar.bz2
gentoo-2-881e96852f9722e039c78ee1cce630a6cb033bf5.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/configliere/configliere-0.4.22.ebuild')
-rw-r--r--dev-ruby/configliere/configliere-0.4.22.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/configliere/configliere-0.4.22.ebuild b/dev-ruby/configliere/configliere-0.4.22.ebuild
new file mode 100644
index 000000000000..fb698029b09c
--- /dev/null
+++ b/dev-ruby/configliere/configliere-0.4.22.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/configliere/configliere-0.4.22.ebuild,v 1.1 2014/10/24 14:51:47 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.textile README.textile FEATURES.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Settings manager for Ruby scripts"
+HOMEPAGE="https://github.com/infochimps-labs/configliere"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/highline-1.5.2
+ >=dev-ruby/multi_json-1.1"
+
+
+all_ruby_prepare() {
+ rm Gemfile* || die
+ sed -i -e "/bundler/d" spec/spec_helper.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+}