summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-03-04 07:16:24 +0000
committerHans de Graaff <graaff@gentoo.org>2014-03-04 07:16:24 +0000
commit29167f64210a50656927a7394eeb1264ecb2809e (patch)
tree28262ea798b3f62bf9e1ffa40286c54736613f32 /dev-ruby/daemon_controller
parentCleanup. (diff)
downloadgentoo-2-29167f64210a50656927a7394eeb1264ecb2809e.tar.gz
gentoo-2-29167f64210a50656927a7394eeb1264ecb2809e.tar.bz2
gentoo-2-29167f64210a50656927a7394eeb1264ecb2809e.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/daemon_controller')
-rw-r--r--dev-ruby/daemon_controller/ChangeLog8
-rw-r--r--dev-ruby/daemon_controller/daemon_controller-1.2.0.ebuild28
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-ruby/daemon_controller/ChangeLog b/dev-ruby/daemon_controller/ChangeLog
index d9c1311a52ce..94a837e8bd0c 100644
--- a/dev-ruby/daemon_controller/ChangeLog
+++ b/dev-ruby/daemon_controller/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/daemon_controller
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemon_controller/ChangeLog,v 1.28 2014/03/04 07:15:16 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemon_controller/ChangeLog,v 1.29 2014/03/04 07:16:24 graaff Exp $
+
+*daemon_controller-1.2.0 (04 Mar 2014)
+
+ 04 Mar 2014; Hans de Graaff <graaff@gentoo.org>
+ +daemon_controller-1.2.0.ebuild:
+ Version bump.
04 Mar 2014; Hans de Graaff <graaff@gentoo.org>
-daemon_controller-1.1.7.ebuild:
diff --git a/dev-ruby/daemon_controller/daemon_controller-1.2.0.ebuild b/dev-ruby/daemon_controller/daemon_controller-1.2.0.ebuild
new file mode 100644
index 000000000000..5845c02f4c54
--- /dev/null
+++ b/dev-ruby/daemon_controller/daemon_controller-1.2.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/daemon_controller/daemon_controller-1.2.0.ebuild,v 1.1 2014/03/04 07:16:24 graaff Exp $
+
+EAPI=5
+
+# jruby → fails tests, looks like Unix sockets are bad on JRuby
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library for starting and stopping specific daemons programmatically in a robust manner."
+HOMEPAGE="http://github.com/FooBarWidget/daemon_controller"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ # fix tests with RSpec 2
+ sed -i -e '1irequire "thread"' spec/test_helper.rb || die
+}