summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-05-01 05:39:35 +0000
committerHans de Graaff <graaff@gentoo.org>2013-05-01 05:39:35 +0000
commit016a98a0f14ff5c3e5f1e7804d1fbc6425a8eef9 (patch)
tree29114395defea8a61a6039333dd44a7059e20515 /dev-ruby/date_validator
parentDownloading from ftp.texmacs.org works again (diff)
downloadgentoo-2-016a98a0f14ff5c3e5f1e7804d1fbc6425a8eef9.tar.gz
gentoo-2-016a98a0f14ff5c3e5f1e7804d1fbc6425a8eef9.tar.bz2
gentoo-2-016a98a0f14ff5c3e5f1e7804d1fbc6425a8eef9.zip
Version bump.
(Portage version: 2.1.11.62/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/date_validator')
-rw-r--r--dev-ruby/date_validator/ChangeLog10
-rw-r--r--dev-ruby/date_validator/date_validator-0.6.4.ebuild45
2 files changed, 52 insertions, 3 deletions
diff --git a/dev-ruby/date_validator/ChangeLog b/dev-ruby/date_validator/ChangeLog
index d1b23c6f0b1b..c47b3adfe8c0 100644
--- a/dev-ruby/date_validator/ChangeLog
+++ b/dev-ruby/date_validator/ChangeLog
@@ -1,10 +1,14 @@
# ChangeLog for dev-ruby/date_validator
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/date_validator/ChangeLog,v 1.1 2012/01/22 11:26:25 flameeyes Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/date_validator/ChangeLog,v 1.2 2013/05/01 05:39:35 graaff Exp $
+
+*date_validator-0.6.4 (01 May 2013)
+
+ 01 May 2013; Hans de Graaff <graaff@gentoo.org> +date_validator-0.6.4.ebuild:
+ Version bump.
*date_validator-0.6.3 (22 Jan 2012)
22 Jan 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+date_validator-0.6.3.ebuild, +metadata.xml:
Initial import of date_validator.
-
diff --git a/dev-ruby/date_validator/date_validator-0.6.4.ebuild b/dev-ruby/date_validator/date_validator-0.6.4.ebuild
new file mode 100644
index 000000000000..e0c5771e5b8d
--- /dev/null
+++ b/dev-ruby/date_validator/date_validator-0.6.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/date_validator/date_validator-0.6.4.ebuild,v 1.1 2013/05/01 05:39:35 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_EXTRADOC="Readme.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+# if ever needed
+#GITHUB_USER="codegram"
+#GITHUB_PROJECT="${PN}"
+#RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple, ORM agnostic, Ruby 1.9 compatible date validator for Rails 3"
+HOMEPAGE="http://github.com/codegram/date_validator"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activemodel-3.0
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/minitest
+ >=dev-ruby/tzinfo-0.3
+ >=dev-ruby/activesupport-3.0
+ )
+ doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/git ls-files/d' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+}