summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-10-22 12:50:11 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-10-22 12:50:11 +0000
commitbf9d850333f09115d6bc7ae07b7a1630836aa5c8 (patch)
tree0d5812bd2b7cdef392e70c8c056e6e7a1bf2ac08 /dev-ruby/date_validator
parentStable for HPPA (bug #526420). (diff)
downloadgentoo-2-bf9d850333f09115d6bc7ae07b7a1630836aa5c8.tar.gz
gentoo-2-bf9d850333f09115d6bc7ae07b7a1630836aa5c8.tar.bz2
gentoo-2-bf9d850333f09115d6bc7ae07b7a1630836aa5c8.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/date_validator')
-rw-r--r--dev-ruby/date_validator/ChangeLog7
-rw-r--r--dev-ruby/date_validator/date_validator-0.7.1.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-ruby/date_validator/ChangeLog b/dev-ruby/date_validator/ChangeLog
index ef3beb46aa81..47319f8bfd6b 100644
--- a/dev-ruby/date_validator/ChangeLog
+++ b/dev-ruby/date_validator/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/date_validator
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/date_validator/ChangeLog,v 1.7 2014/08/06 06:41:51 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/date_validator/ChangeLog,v 1.8 2014/10/22 12:50:11 mrueg Exp $
+
+*date_validator-0.7.1 (22 Oct 2014)
+
+ 22 Oct 2014; Manuel Rüger <mrueg@gentoo.org> +date_validator-0.7.1.ebuild:
+ Version bump.
06 Aug 2014; Manuel Rüger <mrueg@gentoo.org> date_validator-0.7.0.ebuild:
Add ruby20, ruby21 target.
diff --git a/dev-ruby/date_validator/date_validator-0.7.1.ebuild b/dev-ruby/date_validator/date_validator-0.7.1.ebuild
new file mode 100644
index 000000000000..1c536e4d2d5c
--- /dev/null
+++ b/dev-ruby/date_validator/date_validator-0.7.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/date_validator/date_validator-0.7.1.ebuild,v 1.1 2014/10/22 12:50:11 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_EXTRADOC="Readme.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+# if ever needed
+#GITHUB_USER="codegram"
+#GITHUB_PROJECT="${PN}"
+#RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple, ORM agnostic, Ruby 1.9 compatible date validator for Rails 3"
+HOMEPAGE="http://github.com/codegram/date_validator"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activemodel-3.0
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/minitest
+ >=dev-ruby/tzinfo-0.3
+ >=dev-ruby/activesupport-3.0
+ )
+ doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/git ls-files/d' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i \
+ -e '/[Bb]undler/s/^/#/' Rakefile || die
+ # Fix tests
+ sed -i -e "1irequire 'active_support'" test/test_helper.rb || die
+}