summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-02-13 08:47:13 +0000
committerHans de Graaff <graaff@gentoo.org>2010-02-13 08:47:13 +0000
commita829a6b6d2ffde9fff5c2d170dbeab6b9db329a6 (patch)
tree4af37bed4d5b5091f826077916f99c6ad4122ece /dev-ruby/fattr
parentTake into account that the description may contain double quotes and quote th... (diff)
downloadgentoo-2-a829a6b6d2ffde9fff5c2d170dbeab6b9db329a6.tar.gz
gentoo-2-a829a6b6d2ffde9fff5c2d170dbeab6b9db329a6.tar.bz2
gentoo-2-a829a6b6d2ffde9fff5c2d170dbeab6b9db329a6.zip
Revision bump so that gem specification gets generated with fixed eclass to avoid #304723.
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/fattr')
-rw-r--r--dev-ruby/fattr/ChangeLog8
-rw-r--r--dev-ruby/fattr/fattr-2.1.0-r2.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-ruby/fattr/ChangeLog b/dev-ruby/fattr/ChangeLog
index 9bb94236b05a..c4c37a60f480 100644
--- a/dev-ruby/fattr/ChangeLog
+++ b/dev-ruby/fattr/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/fattr
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fattr/ChangeLog,v 1.5 2010/01/25 06:50:39 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fattr/ChangeLog,v 1.6 2010/02/13 08:47:13 graaff Exp $
+
+*fattr-2.1.0-r2 (13 Feb 2010)
+
+ 13 Feb 2010; Hans de Graaff <graaff@gentoo.org> +fattr-2.1.0-r2.ebuild:
+ Revision bump so that gem specification gets generated with fixed eclass
+ to avoid #304723.
*fattr-2.1.0-r1 (25 Jan 2010)
diff --git a/dev-ruby/fattr/fattr-2.1.0-r2.ebuild b/dev-ruby/fattr/fattr-2.1.0-r2.ebuild
new file mode 100644
index 000000000000..02baac57363f
--- /dev/null
+++ b/dev-ruby/fattr/fattr-2.1.0-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fattr/fattr-2.1.0-r2.ebuild,v 1.1 2010/02/13 08:47:13 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="fattr.rb is a \"fatter attr\" for ruby."
+HOMEPAGE="http://rubyforge.org/projects/codeforpeople/"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_bdepend test "virtual/ruby-test-unit"
+
+each_ruby_test() {
+ ${RUBY} test/fattr.rb || die "Tests failed."
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r samples
+}