summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-31 16:40:32 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-31 16:40:32 +0000
commit9ca921c12378795daf3dcc840251d1b84ebcb1f2 (patch)
tree93b863a50d8dcef2f4b1af72d00168b2cf109f69 /dev-ruby/fxruby
parentCleanup old, version bump to beta version with ebuild cleanup. (diff)
downloadgentoo-2-9ca921c12378795daf3dcc840251d1b84ebcb1f2.tar.gz
gentoo-2-9ca921c12378795daf3dcc840251d1b84ebcb1f2.tar.bz2
gentoo-2-9ca921c12378795daf3dcc840251d1b84ebcb1f2.zip
Revision bump to fix bugs #396541, #396279, #396277.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/fxruby')
-rw-r--r--dev-ruby/fxruby/ChangeLog7
-rw-r--r--dev-ruby/fxruby/fxruby-1.6.20-r1.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/dev-ruby/fxruby/ChangeLog b/dev-ruby/fxruby/ChangeLog
index 4dc65d39b9ae..54930c358552 100644
--- a/dev-ruby/fxruby/ChangeLog
+++ b/dev-ruby/fxruby/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/fxruby
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/ChangeLog,v 1.87 2011/01/15 12:12:45 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/ChangeLog,v 1.88 2011/12/31 16:40:32 graaff Exp $
+
+*fxruby-1.6.20-r1 (31 Dec 2011)
+
+ 31 Dec 2011; Hans de Graaff <graaff@gentoo.org> +fxruby-1.6.20-r1.ebuild:
+ Revision bump to fix bugs #396541, #396279, #396277.
15 Jan 2011; Hans de Graaff <graaff@gentoo.org> -fxruby-1.6.19.ebuild:
Remove old version.
diff --git a/dev-ruby/fxruby/fxruby-1.6.20-r1.ebuild b/dev-ruby/fxruby/fxruby-1.6.20-r1.ebuild
new file mode 100644
index 000000000000..49b0ab1c44a0
--- /dev/null
+++ b/dev-ruby/fxruby/fxruby-1.6.20-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fxruby/fxruby-1.6.20-r1.ebuild,v 1.1 2011/12/31 16:40:32 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_NAME="fxruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt index.html README README.txt TODO"
+
+inherit multilib ruby-fakegem toolchain-funcs
+
+DESCRIPTION="Ruby language binding to the FOX GUI toolkit"
+HOMEPAGE="http://www.fxruby.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="1.6"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="examples doc"
+
+DEPEND="x11-libs/fox:1.6
+ >=x11-libs/fxscintilla-1.62-r1"
+RDEPEND="${RDEPEND}"
+
+# Tests fail with a memory corruption error. Restrict the tests for
+# now. We did not run tests with older versions so we assume this is
+# not a regression for now.
+RESTRICT="test"
+#ruby_add_bdepend "test? ( dev-ruby/ruby-opengl )"
+
+ruby_add_bdepend "dev-ruby/hoe"
+
+all_ruby_prepare() {
+ sed -i -e '/\[:compile\]/d' Rakefile || die
+ sed -i -e 's:libs, "fxscintilla":libs, "fxscintilla-1.6":g' \
+ ext/fox16/extconf.rb || die "sed error"
+ einfo "Avoid -O0 builds"
+ sed -i -e 's:-O0 -I:-I:' \
+ ext/fox16/extconf.rb || die "Can't fix forced -O0"
+
+ # Use our own metadata since the distributed version doesn't work
+ # with recent rubygems, bug 396541
+ rm ../metadata || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/fox16 extconf.rb || die
+}
+
+each_ruby_compile() {
+ CXX=$(tc-getCXX) emake -Cext/fox16 || die
+ cp ext/fox16/fox16$(get_modname) lib/ || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ if use examples; then
+ for dir in sample samples example examples; do
+ if [ -d ${dir} ] ; then
+ dodir /usr/share/doc/${PF}
+ cp -pPR ${dir} "${D}"/usr/share/doc/${PF} || die "cp failed"
+ fi
+ done
+ fi
+}