summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-08-06 18:19:05 +0000
committerHans de Graaff <graaff@gentoo.org>2012-08-06 18:19:05 +0000
commita8689ab36e1e488ec1512a747a7a0002363b7bc0 (patch)
tree19afe9c24e4ec730f1bb63acdaf67a98018ec9b6 /dev-ruby/gnuplot
parentCleanup. (diff)
downloadgentoo-2-a8689ab36e1e488ec1512a747a7a0002363b7bc0.tar.gz
gentoo-2-a8689ab36e1e488ec1512a747a7a0002363b7bc0.tar.bz2
gentoo-2-a8689ab36e1e488ec1512a747a7a0002363b7bc0.zip
Version bump.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/gnuplot')
-rw-r--r--dev-ruby/gnuplot/ChangeLog7
-rw-r--r--dev-ruby/gnuplot/gnuplot-2.5.0.ebuild32
2 files changed, 38 insertions, 1 deletions
diff --git a/dev-ruby/gnuplot/ChangeLog b/dev-ruby/gnuplot/ChangeLog
index a7c67b373262..6ca58d852fef 100644
--- a/dev-ruby/gnuplot/ChangeLog
+++ b/dev-ruby/gnuplot/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/gnuplot
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gnuplot/ChangeLog,v 1.15 2012/08/06 18:16:35 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gnuplot/ChangeLog,v 1.16 2012/08/06 18:19:05 graaff Exp $
+
+*gnuplot-2.5.0 (06 Aug 2012)
+
+ 06 Aug 2012; Hans de Graaff <graaff@gentoo.org> +gnuplot-2.5.0.ebuild:
+ Version bump.
06 Aug 2012; Hans de Graaff <graaff@gentoo.org> -gnuplot-2.3.6.ebuild:
Cleanup.
diff --git a/dev-ruby/gnuplot/gnuplot-2.5.0.ebuild b/dev-ruby/gnuplot/gnuplot-2.5.0.ebuild
new file mode 100644
index 000000000000..d5031b3b5bd4
--- /dev/null
+++ b/dev-ruby/gnuplot/gnuplot-2.5.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gnuplot/gnuplot-2.5.0.ebuild,v 1.1 2012/08/06 18:19:05 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="AUTHORS.txt ChangeLog README.textile"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Gnuplot drawing library - Ruby Bindings"
+HOMEPAGE="http://rgplot.rubyforge.org/"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+SLOT="0"
+
+RDEPEND="${RDEPEND} sci-visualization/gnuplot"
+
+all_ruby_prepare() {
+ # Existing metadata causes a crash in jruby, so use our own.
+ rm ../metadata || die "Unable to remove metadata."
+}
+
+each_ruby_test() {
+ ${RUBY} -Ctest test_gnuplot.rb || die
+}