summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-04-30 06:40:27 +0000
committerHans de Graaff <graaff@gentoo.org>2011-04-30 06:40:27 +0000
commitb90f56665b1a026773139310533f0418866844b8 (patch)
tree694aa8edaa3c3adf1c0f8a05b3addb12520de89b /dev-ruby/haml
parentVersion bump. Depend on bouncy-castle-java to allow tests to run. Drop x86 ke... (diff)
downloadgentoo-2-b90f56665b1a026773139310533f0418866844b8.tar.gz
gentoo-2-b90f56665b1a026773139310533f0418866844b8.tar.bz2
gentoo-2-b90f56665b1a026773139310533f0418866844b8.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/haml')
-rw-r--r--dev-ruby/haml/ChangeLog7
-rw-r--r--dev-ruby/haml/haml-3.1.1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/haml/ChangeLog b/dev-ruby/haml/ChangeLog
index 38f65551d4ab..e6dd2b19dd2d 100644
--- a/dev-ruby/haml/ChangeLog
+++ b/dev-ruby/haml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/haml
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.62 2011/02/28 00:11:57 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.63 2011/04/30 06:40:27 graaff Exp $
+
+*haml-3.1.1 (30 Apr 2011)
+
+ 30 Apr 2011; Hans de Graaff <graaff@gentoo.org> +haml-3.1.1.ebuild:
+ Version bump.
28 Feb 2011; Brent Baude <ranger@gentoo.org> haml-3.0.25-r1.ebuild:
Marking haml-3.0.25-r1 ~ppc for bug 351212
diff --git a/dev-ruby/haml/haml-3.1.1.ebuild b/dev-ruby/haml/haml-3.1.1.ebuild
new file mode 100644
index 000000000000..3ceb7569e342
--- /dev/null
+++ b/dev-ruby/haml/haml-3.1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-3.1.1.ebuild,v 1.1 2011/04/30 06:40:27 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING README.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb VERSION VERSION_NAME vendor"
+
+inherit ruby-fakegem
+
+DESCRIPTION="HAML - a ruby web page templating engine"
+HOMEPAGE="http://haml-lang.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+# TODO: haml has some emacs modes that it could be installing, in case
+IUSE=""
+
+# The html engine requires hpricot
+ruby_add_rdepend "dev-ruby/hpricot dev-ruby/fssm"
+
+# It could use merb during testing as well, but it's not mandatory
+ruby_add_bdepend "
+ test? (
+ virtual/ruby-test-unit
+ dev-ruby/erubis
+ dev-ruby/rails
+ dev-ruby/ruby_parser
+ )
+ doc? (
+ dev-ruby/yard
+ dev-ruby/maruku
+ )"