summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-08-08 14:09:58 +0000
committerHans de Graaff <graaff@gentoo.org>2010-08-08 14:09:58 +0000
commitd5c2d26b7f53e5cb59629b1464e2cf81148415e2 (patch)
treec6823f82f0f6e6ae220a9a8af7371159c67a6180 /dev-ruby/haml
parentalpha/ia64/sparc stable (diff)
downloadgentoo-2-d5c2d26b7f53e5cb59629b1464e2cf81148415e2.tar.gz
gentoo-2-d5c2d26b7f53e5cb59629b1464e2cf81148415e2.tar.bz2
gentoo-2-d5c2d26b7f53e5cb59629b1464e2cf81148415e2.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/haml')
-rw-r--r--dev-ruby/haml/ChangeLog7
-rw-r--r--dev-ruby/haml/haml-3.0.16.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-ruby/haml/ChangeLog b/dev-ruby/haml/ChangeLog
index 9ce380a69b80..74739b67f576 100644
--- a/dev-ruby/haml/ChangeLog
+++ b/dev-ruby/haml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/haml
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.45 2010/06/30 19:17:22 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.46 2010/08/08 14:09:58 graaff Exp $
+
+*haml-3.0.16 (08 Aug 2010)
+
+ 08 Aug 2010; Hans de Graaff <graaff@gentoo.org> +haml-3.0.16.ebuild:
+ Version bump.
*haml-3.0.13-r1 (30 Jun 2010)
diff --git a/dev-ruby/haml/haml-3.0.16.ebuild b/dev-ruby/haml/haml-3.0.16.ebuild
new file mode 100644
index 000000000000..24dae57a9834
--- /dev/null
+++ b/dev-ruby/haml/haml-3.0.16.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-3.0.16.ebuild,v 1.1 2010/08/08 14:09:58 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING README.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb VERSION VERSION_NAME"
+
+inherit ruby-fakegem
+
+DESCRIPTION="HAML - a ruby web page templating engine"
+HOMEPAGE="http://haml.hamptoncatlin.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# TODO: haml has some emacs modes that it could be installing, in case
+IUSE=""
+
+# The html engine requires hpricot
+ruby_add_rdepend dev-ruby/hpricot
+
+# It could use merb during testing as well, but it's not mandatory
+ruby_add_bdepend "
+ test? (
+ virtual/ruby-test-unit
+ dev-ruby/erubis
+ dev-ruby/actionpack
+ )
+ doc? (
+ dev-ruby/yard
+ dev-ruby/maruku
+ )"