summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-04-20 17:36:52 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-04-20 17:36:52 +0000
commitada912b788beb89cb0568b43b27be201bb954a60 (patch)
tree3f7c0841e155ef9116cb5e1407cc3cd8d1658554 /dev-ruby/highline
parentVersion bump. (diff)
downloadgentoo-2-ada912b788beb89cb0568b43b27be201bb954a60.tar.gz
gentoo-2-ada912b788beb89cb0568b43b27be201bb954a60.tar.bz2
gentoo-2-ada912b788beb89cb0568b43b27be201bb954a60.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/highline')
-rw-r--r--dev-ruby/highline/ChangeLog7
-rw-r--r--dev-ruby/highline/highline-1.7.2.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-ruby/highline/ChangeLog b/dev-ruby/highline/ChangeLog
index aec718f227a5..8652e82703e4 100644
--- a/dev-ruby/highline/ChangeLog
+++ b/dev-ruby/highline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/highline
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/highline/ChangeLog,v 1.103 2015/04/03 15:01:08 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/highline/ChangeLog,v 1.104 2015/04/20 17:36:52 mrueg Exp $
+
+*highline-1.7.2 (20 Apr 2015)
+
+ 20 Apr 2015; Manuel Rüger <mrueg@gentoo.org> +highline-1.7.2.ebuild:
+ Version bump.
03 Apr 2015; Hans de Graaff <graaff@gentoo.org> -highline-1.6.19.ebuild:
Cleanup.
diff --git a/dev-ruby/highline/highline-1.7.2.ebuild b/dev-ruby/highline/highline-1.7.2.ebuild
new file mode 100644
index 000000000000..4ca540f22274
--- /dev/null
+++ b/dev-ruby/highline/highline-1.7.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/highline/highline-1.7.2.ebuild,v 1.1 2015/04/20 17:36:52 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.rdoc TODO"
+RUBY_FAKEGEM_DOCDIR="doc/html"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Highline is a high-level command-line IO library for ruby"
+HOMEPAGE="https://github.com/JEG2/highline"
+
+IUSE=""
+LICENSE="|| ( GPL-2 Ruby )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+
+all_ruby_prepare() {
+ # fix up gemspec file not to call git
+ sed -i -e '/git ls-files/d' highline.gemspec || die
+
+ # Avoid unneeded dependencies
+ sed -i -e '/\(bundler\|code_statistics\)/ s:^:#:' \
+ -e '/PackageTask/,/end/ s:^:#:' Rakefile || die
+
+ # Avoid tests that require a real console because we can't provide
+ # that when running tests through portage. These should pass when
+ # run in a console. We should probably narrow this down more to the
+ # specific tests.
+ rm test/tc_highline.rb || die
+
+ sed -i -e '/test_question_options/,/^ end/ s:^:#:' \
+ -e '/test_paged_print_infinite_loop_bug/,/^ end/ s:^:#:' \
+ -e '/test_cancel_paging/,/^ end/ s:^:#:' \
+ test/tc_menu.rb || die
+}