summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-12-27 03:26:54 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-12-27 03:26:54 +0000
commit1ea08548775182c6461ef5cd9f3b3e13392304bf (patch)
treee3af3e38da9cc60f1784b65038c3ebd4d9d63f02 /dev-ruby/hike/hike-1.2.3-r1.ebuild
parentDrop vulnerable versions, bug 493292. (diff)
downloadgentoo-2-1ea08548775182c6461ef5cd9f3b3e13392304bf.tar.gz
gentoo-2-1ea08548775182c6461ef5cd9f3b3e13392304bf.tar.bz2
gentoo-2-1ea08548775182c6461ef5cd9f3b3e13392304bf.zip
Add ruby21 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/hike/hike-1.2.3-r1.ebuild')
-rw-r--r--dev-ruby/hike/hike-1.2.3-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/hike/hike-1.2.3-r1.ebuild b/dev-ruby/hike/hike-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..5c04fe95d1cf
--- /dev/null
+++ b/dev-ruby/hike/hike-1.2.3-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hike/hike-1.2.3-r1.ebuild,v 1.1 2013/12/27 03:26:54 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hike is a Ruby library for finding files in a set of paths."
+HOMEPAGE="https://github.com/sstephenson/hike"
+LICENSE="MIT"
+SRC_URI="https://github.com/sstephenson/hike/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test -S testrb test || die
+}