summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-08-26 06:15:22 +0000
committerHans de Graaff <graaff@gentoo.org>2011-08-26 06:15:22 +0000
commit026fd1412bf8096cfc90a55057b75454bdb29d6f (patch)
tree6695035e26b408c8755c7661fab85ccea7767122 /dev-ruby/hoe
parentVersion bump. (diff)
downloadgentoo-2-026fd1412bf8096cfc90a55057b75454bdb29d6f.tar.gz
gentoo-2-026fd1412bf8096cfc90a55057b75454bdb29d6f.tar.bz2
gentoo-2-026fd1412bf8096cfc90a55057b75454bdb29d6f.zip
Version bump.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/hoe')
-rw-r--r--dev-ruby/hoe/ChangeLog7
-rw-r--r--dev-ruby/hoe/hoe-2.12.2.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-ruby/hoe/ChangeLog b/dev-ruby/hoe/ChangeLog
index 3e80a3a0702a..47c8e1102bbe 100644
--- a/dev-ruby/hoe/ChangeLog
+++ b/dev-ruby/hoe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/hoe
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.119 2011/08/20 08:45:42 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/ChangeLog,v 1.120 2011/08/26 06:15:22 graaff Exp $
+
+*hoe-2.12.2 (26 Aug 2011)
+
+ 26 Aug 2011; Hans de Graaff <graaff@gentoo.org> +hoe-2.12.2.ebuild:
+ Version bump.
*hoe-2.12.0 (20 Aug 2011)
diff --git a/dev-ruby/hoe/hoe-2.12.2.ebuild b/dev-ruby/hoe/hoe-2.12.2.ebuild
new file mode 100644
index 000000000000..864c5a64366c
--- /dev/null
+++ b/dev-ruby/hoe/hoe-2.12.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/hoe/hoe-2.12.2.ebuild,v 1.1 2011/08/26 06:15:22 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt Manifest.txt README.txt"
+
+RUBY_FAKEGEM_EXTRAINSTALL="template"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe extends rake to provide full project automation."
+HOMEPAGE="http://seattlerb.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# - also requires dev-ruby/hoe-seattlerb for 1.9;
+# - dev-ruby/gemcutter is an optional dependency at both runtime and
+# test-time, at least for us;
+# - rubyforge is loaded at runtime when needed, so we don't strictly
+# depend on it at runtime, but we need it for tests (for now);
+ruby_add_bdepend "test? ( dev-ruby/minitest >=dev-ruby/rubyforge-2.0.4 )"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.7"
+
+all_ruby_prepare() {
+ # Make test regexp more lenient to cover the way we name the binaries.
+ sed -i -e 's/sudo gem/sudo .?gem/' -e 's/\^gem/^.?gem/' test/test_hoe.rb || die
+}