summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-06-04 07:23:24 +0000
committerHans de Graaff <graaff@gentoo.org>2011-06-04 07:23:24 +0000
commit2bee33470bb184300023cc82c82757467f861345 (patch)
treee0777abf2f285202583767ada5e09950621e68a7 /dev-ruby/httpclient
parent[bump] dev-perl/ExtUtils-XSpp-0.160.200 (diff)
downloadgentoo-2-2bee33470bb184300023cc82c82757467f861345.tar.gz
gentoo-2-2bee33470bb184300023cc82c82757467f861345.tar.bz2
gentoo-2-2bee33470bb184300023cc82c82757467f861345.zip
Version bump.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/httpclient')
-rw-r--r--dev-ruby/httpclient/ChangeLog7
-rw-r--r--dev-ruby/httpclient/httpclient-2.2.1.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/httpclient/ChangeLog b/dev-ruby/httpclient/ChangeLog
index 0bfa99295a17..fc0dcc98f471 100644
--- a/dev-ruby/httpclient/ChangeLog
+++ b/dev-ruby/httpclient/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/httpclient
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/ChangeLog,v 1.25 2011/04/10 06:35:35 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/ChangeLog,v 1.26 2011/06/04 07:23:24 graaff Exp $
+
+*httpclient-2.2.1 (04 Jun 2011)
+
+ 04 Jun 2011; Hans de Graaff <graaff@gentoo.org> +httpclient-2.2.1.ebuild:
+ Version bump.
10 Apr 2011; Hans de Graaff <graaff@gentoo.org>
-httpclient-2.1.5.2-r2.ebuild, -httpclient-2.1.6.ebuild:
diff --git a/dev-ruby/httpclient/httpclient-2.2.1.ebuild b/dev-ruby/httpclient/httpclient-2.2.1.ebuild
new file mode 100644
index 000000000000..10b55d456f18
--- /dev/null
+++ b/dev-ruby/httpclient/httpclient-2.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/httpclient/httpclient-2.2.1.ebuild,v 1.1 2011/06/04 07:23:24 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="-Ilib test"
+RUBY_FAKEGEM_TASK_DOC="-Ilib doc"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="'httpclient' gives something like the functionality of libwww-perl (LWP) in Ruby"
+HOMEPAGE="https://github.com/nahi/httpclient"
+SRC_URI="https://github.com/nahi/httpclient/tarball/RELEASE_2_2_0_1 -> ${P}.tgz"
+S="${WORKDIR}/nahi-httpclient-*"
+
+LICENSE="Ruby"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${RDEPEND}
+ !dev-ruby/http-access2"
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+
+# JRuby-specific dependency
+USE_RUBY="jruby" ruby_add_rdepend dev-ruby/jruby-openssl
+
+all_ruby_prepare() {
+ # Remove test file with failing tests so that we can at least run
+ # the other tests. Reported upstream:
+ # https://github.com/nahi/httpclient/issues/39
+ rm test/test_httpclient.rb || die
+}