summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-18 18:40:40 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-18 18:40:40 +0000
commit3a82fde608b5371444ac14cf9948187bd25f0d7b (patch)
tree7ec8148bcca906f518b19f0a4e0847aadda0eb97 /dev-ruby/i18n
parentAdd ~arm (diff)
downloadgentoo-2-3a82fde608b5371444ac14cf9948187bd25f0d7b.tar.gz
gentoo-2-3a82fde608b5371444ac14cf9948187bd25f0d7b.tar.bz2
gentoo-2-3a82fde608b5371444ac14cf9948187bd25f0d7b.zip
Remove blocker over activesupport, and add a 0.1 slot for activesupport 2.3.5 to work properly.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/i18n')
-rw-r--r--dev-ruby/i18n/ChangeLog9
-rw-r--r--dev-ruby/i18n/i18n-0.1.3.ebuild40
-rw-r--r--dev-ruby/i18n/i18n-0.3.3.ebuild4
3 files changed, 50 insertions, 3 deletions
diff --git a/dev-ruby/i18n/ChangeLog b/dev-ruby/i18n/ChangeLog
index beef09328ca3..cfe79cba5fd3 100644
--- a/dev-ruby/i18n/ChangeLog
+++ b/dev-ruby/i18n/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/i18n
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.4 2010/01/18 17:47:20 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.5 2010/01/18 18:40:40 flameeyes Exp $
+
+*i18n-0.1.3 (18 Jan 2010)
+
+ 18 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org> +i18n-0.1.3.ebuild,
+ i18n-0.3.3.ebuild:
+ Remove blocker over activesupport, and add a 0.1 slot for activesupport
+ 2.3.5 to work properly.
18 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org> -i18n-0.3.2.ebuild,
i18n-0.3.3.ebuild:
diff --git a/dev-ruby/i18n/i18n-0.1.3.ebuild b/dev-ruby/i18n/i18n-0.1.3.ebuild
new file mode 100644
index 000000000000..73c739c3741c
--- /dev/null
+++ b/dev-ruby/i18n/i18n-0.1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/i18n-0.1.3.ebuild,v 1.1 2010/01/18 18:40:40 flameeyes Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.textile"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Add Internationalization support to your Ruby application."
+HOMEPAGE="http://rails-i18n.org/"
+
+# We have a valid expectance that *this* is the correct tarball for
+# version 0.1.3, unfortunately there is *no such official release* as
+# the one bundled with activesupport. On the other hand, this seems to
+# be it, minus some test changes.
+SRC_URI="http://github.com/svenfuchs/i18n/tarball/38d85ea3b8eec032c1b0898a30f8010917416d9d -> ${PN}-git-${PV}.tgz"
+S="${WORKDIR}/svenfuchs-${PN}-38d85ea"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~ppc-macos ~x64-solaris"
+IUSE=""
+
+ruby_add_bdepend test "dev-ruby/mocha dev-ruby/activesupport"
+
+src_prepare() {
+ ruby-ng_src_prepare
+ chmod 0755 ${WORKDIR/work/homedir} || die "Failed to fix permissions on home"
+}
+
+src_test() {
+ chmod 0755 ${WORKDIR/work/homedir} || die "Failed to fix permissions on home"
+ ruby-ng_src_test
+}
diff --git a/dev-ruby/i18n/i18n-0.3.3.ebuild b/dev-ruby/i18n/i18n-0.3.3.ebuild
index 683fd4b64f13..38cde6ee4919 100644
--- a/dev-ruby/i18n/i18n-0.3.3.ebuild
+++ b/dev-ruby/i18n/i18n-0.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/i18n-0.3.3.ebuild,v 1.3 2010/01/18 17:47:20 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/i18n-0.3.3.ebuild,v 1.4 2010/01/18 18:40:40 flameeyes Exp $
EAPI=2
@@ -24,7 +24,7 @@ SLOT="$(get_version_component_range 1-2)"
KEYWORDS="~amd64 ~ppc-macos ~x64-solaris"
IUSE=""
-DEPEND="!<dev-ruby/activesupport-2.3.5-r2"
+DEPEND=""
RDEPEND="${DEPEND}"
# This is an optional runtime dependency, for now consider it only a