summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-11-24 13:46:16 +0000
committerHans de Graaff <graaff@gentoo.org>2012-11-24 13:46:16 +0000
commitd6db4baed5ec4fb517ba29fa26ff8e9d31b8aa29 (patch)
treeb10fd7e65f748fefda07c0aef31b4fca11942ccd /dev-ruby/i18n
parentVersion bump (diff)
downloadgentoo-2-d6db4baed5ec4fb517ba29fa26ff8e9d31b8aa29.tar.gz
gentoo-2-d6db4baed5ec4fb517ba29fa26ff8e9d31b8aa29.tar.bz2
gentoo-2-d6db4baed5ec4fb517ba29fa26ff8e9d31b8aa29.zip
Version bump. Ebuild from ruby overlay by Michel Boaventura.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/i18n')
-rw-r--r--dev-ruby/i18n/ChangeLog7
-rw-r--r--dev-ruby/i18n/i18n-0.6.1.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/dev-ruby/i18n/ChangeLog b/dev-ruby/i18n/ChangeLog
index d8d90ed2fcee..098a12807cf1 100644
--- a/dev-ruby/i18n/ChangeLog
+++ b/dev-ruby/i18n/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/i18n
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.49 2012/09/16 12:20:44 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/ChangeLog,v 1.50 2012/11/24 13:46:16 graaff Exp $
+
+*i18n-0.6.1 (24 Nov 2012)
+
+ 24 Nov 2012; Hans de Graaff <graaff@gentoo.org> +i18n-0.6.1.ebuild:
+ Version bump. Ebuild from ruby overlay by Michel Boaventura.
16 Sep 2012; Pacho Ramos <pacho@gentoo.org> -files/i18n-0.3.7-gentoo.patch,
-i18n-0.1.3.ebuild, -i18n-0.3.7.ebuild:
diff --git a/dev-ruby/i18n/i18n-0.6.1.ebuild b/dev-ruby/i18n/i18n-0.6.1.ebuild
new file mode 100644
index 000000000000..ff5cd7edf0c1
--- /dev/null
+++ b/dev-ruby/i18n/i18n-0.6.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/i18n/i18n-0.6.1.ebuild,v 1.1 2012/11/24 13:46:16 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 jruby ree18 ruby19"
+
+RUBY_FAKEGEM_RECIPE_TEST="test"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.textile README.textile"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Add Internationalization support to your Ruby application."
+HOMEPAGE="http://rails-i18n.org/"
+
+LICENSE="MIT"
+SLOT="0.6"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/activesupport dev-ruby/mocha dev-ruby/test_declarative )"
+
+each_ruby_test() {
+ ${RUBY} -w -Ilib -Itest test/all.rb
+}
+
+all_ruby_prepare() {
+ #Bundler isn't really necessary here, and it doesn't work with jruby
+ sed -i -e "15s/require 'bundler\/setup'//" test/test_helper.rb || die
+}