summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-10-04 20:02:33 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-10-04 20:02:33 +0000
commit245b242c941479ce21e6426f18df873291ccbe23 (patch)
tree29c70f042141ff682e0d6f3f443d10d4230df775 /dev-ruby/kramdown
parentVersion bump. (diff)
downloadgentoo-2-245b242c941479ce21e6426f18df873291ccbe23.tar.gz
gentoo-2-245b242c941479ce21e6426f18df873291ccbe23.tar.bz2
gentoo-2-245b242c941479ce21e6426f18df873291ccbe23.zip
Version bump.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/kramdown')
-rw-r--r--dev-ruby/kramdown/ChangeLog7
-rw-r--r--dev-ruby/kramdown/kramdown-1.4.2.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ruby/kramdown/ChangeLog b/dev-ruby/kramdown/ChangeLog
index a7980c420978..3fa55b8d6898 100644
--- a/dev-ruby/kramdown/ChangeLog
+++ b/dev-ruby/kramdown/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/kramdown
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/kramdown/ChangeLog,v 1.38 2014/09/03 12:41:39 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/kramdown/ChangeLog,v 1.39 2014/10/04 20:02:33 mrueg Exp $
+
+*kramdown-1.4.2 (04 Oct 2014)
+
+ 04 Oct 2014; Manuel Rüger <mrueg@gentoo.org> +kramdown-1.4.2.ebuild:
+ Version bump.
03 Sep 2014; Manuel Rüger <mrueg@gentoo.org> -kramdown-0.14.2.ebuild,
-kramdown-1.2.0-r1.ebuild:
diff --git a/dev-ruby/kramdown/kramdown-1.4.2.ebuild b/dev-ruby/kramdown/kramdown-1.4.2.ebuild
new file mode 100644
index 000000000000..d528884cd8e7
--- /dev/null
+++ b/dev-ruby/kramdown/kramdown-1.4.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/kramdown/kramdown-1.4.2.ebuild,v 1.1 2014/10/04 20:02:33 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="README.md AUTHORS CONTRIBUTERS"
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Yet-another-markdown-parser but fast, pure Ruby, using a strict syntax definition"
+HOMEPAGE="http://kramdown.rubyforge.org/"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="latex"
+
+LATEX_DEPS="latex? ( dev-texlive/texlive-latex dev-texlive/texlive-latexextra )"
+RDEPEND+=" ${LATEX_DEPS}"
+DEPEND+=" test? ( ${LATEX_DEPS} app-text/htmltidy )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )
+ test? ( >=dev-ruby/coderay-1.0.0
+ >=dev-ruby/prawn-1.3.0
+ dev-ruby/prawn-table
+ >=dev-ruby/stringex-1.5.1 )"
+
+all_ruby_prepare() {
+ if ! use latex; then
+ # Remove latex tests. They will fail gracefully when latex isn't
+ # present at all, but not when components are missing (most
+ # notable ucs.sty).
+ sed -i -e '/latex -v/,/^ end/ s:^:#:' test/test_files.rb || die
+ fi
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/man1/kramdown.1
+}