summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-01-30 07:43:07 +0000
committerHans de Graaff <graaff@gentoo.org>2014-01-30 07:43:07 +0000
commitdfe9253d799c8e0c7d88cfb829b5b5e208e64e0a (patch)
tree7cb723ff02dd3ade24f171f542159eed1e2fa8dd /dev-ruby/logging/logging-1.8.2.ebuild
parentFixed #499104 (diff)
downloadgentoo-2-dfe9253d799c8e0c7d88cfb829b5b5e208e64e0a.tar.gz
gentoo-2-dfe9253d799c8e0c7d88cfb829b5b5e208e64e0a.tar.bz2
gentoo-2-dfe9253d799c8e0c7d88cfb829b5b5e208e64e0a.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/logging/logging-1.8.2.ebuild')
-rw-r--r--dev-ruby/logging/logging-1.8.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/logging/logging-1.8.2.ebuild b/dev-ruby/logging/logging-1.8.2.ebuild
new file mode 100644
index 000000000000..e9fd6fd75107
--- /dev/null
+++ b/dev-ruby/logging/logging-1.8.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/logging/logging-1.8.2.ebuild,v 1.1 2014/01/30 07:43:07 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RAKE_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="version.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Flexible logging library for use in Ruby programs based on the design of Java's log4j library"
+HOMEPAGE="http://rubygems.org/gems/logging"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/little-plugger-1.1.3 >=dev-ruby/multi_json-1.3.6"
+
+ruby_add_bdepend "dev-ruby/bones test? ( dev-ruby/flexmock )"