summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Wilmott <p8952@gentoo.org>2014-05-06 21:19:35 +0000
committerPeter Wilmott <p8952@gentoo.org>2014-05-06 21:19:35 +0000
commit2547bb82f5b522403940d6de1d1aa49a59dca18f (patch)
tree91e90542e0f70e767de9d3a127af5e6d864e09bc /dev-ruby/loquacious
parentamd64 stable wrt bug #504210 (diff)
downloadgentoo-2-2547bb82f5b522403940d6de1d1aa49a59dca18f.tar.gz
gentoo-2-2547bb82f5b522403940d6de1d1aa49a59dca18f.tar.bz2
gentoo-2-2547bb82f5b522403940d6de1d1aa49a59dca18f.zip
Drop ruby18 target, add ruby21 target.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-ruby/loquacious')
-rw-r--r--dev-ruby/loquacious/ChangeLog9
-rw-r--r--dev-ruby/loquacious/loquacious-1.9.1-r2.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-ruby/loquacious/ChangeLog b/dev-ruby/loquacious/ChangeLog
index 0d081d5fe078..e58a1529d0ba 100644
--- a/dev-ruby/loquacious/ChangeLog
+++ b/dev-ruby/loquacious/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/loquacious
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/loquacious/ChangeLog,v 1.20 2013/11/02 19:57:51 mrueg Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/loquacious/ChangeLog,v 1.21 2014/05/06 21:19:35 p8952 Exp $
+
+*loquacious-1.9.1-r2 (06 May 2014)
+
+ 06 May 2014; Peter Wilmott <p8952@gentoo.org> +loquacious-1.9.1-r2.ebuild:
+ Drop ruby18 target, add ruby21 target.
02 Nov 2013; Manuel Rüger <mrueg@gentoo.org> -loquacious-1.9.1.ebuild:
Cleanup old.
diff --git a/dev-ruby/loquacious/loquacious-1.9.1-r2.ebuild b/dev-ruby/loquacious/loquacious-1.9.1-r2.ebuild
new file mode 100644
index 000000000000..4bd3706dfb23
--- /dev/null
+++ b/dev-ruby/loquacious/loquacious-1.9.1-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/loquacious/loquacious-1.9.1-r2.ebuild,v 1.1 2014/05/06 21:19:35 p8952 Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Descriptive configuration files for Ruby written in Ruby"
+HOMEPAGE="http://github.com/TwP/loquacious"
+
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+all_ruby_prepare() {
+ # Remove metadata because it confuses jruby.
+ rm ../metadata || die
+}
+
+all_ruby_compile() {
+ if use doc; then
+ rdoc lib || die "Documentation generation failed."
+ fi
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+}