summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-12 23:51:39 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-12 23:51:39 +0000
commitdea89c587fcfbcdf71ebe2646056f4506d1e0ab2 (patch)
tree0a4d6abe8032642f0fda6e2853952db3d80a42bf /dev-ruby/mocha/mocha-0.12.3.ebuild
parentVersion bump. (diff)
downloadgentoo-2-dea89c587fcfbcdf71ebe2646056f4506d1e0ab2.tar.gz
gentoo-2-dea89c587fcfbcdf71ebe2646056f4506d1e0ab2.tar.bz2
gentoo-2-dea89c587fcfbcdf71ebe2646056f4506d1e0ab2.zip
Version bump; use test-unit-2 and the helper function for testing (more consistent among implementations).
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/mocha/mocha-0.12.3.ebuild')
-rw-r--r--dev-ruby/mocha/mocha-0.12.3.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-ruby/mocha/mocha-0.12.3.ebuild b/dev-ruby/mocha/mocha-0.12.3.ebuild
new file mode 100644
index 000000000000..1124af020153
--- /dev/null
+++ b/dev-ruby/mocha/mocha-0.12.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mocha/mocha-0.12.3.ebuild,v 1.1 2012/08/12 23:51:39 flameeyes Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_TEST="test:units"
+
+RUBY_FAKEGEM_TASK_DOC="yardoc"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc RELEASE.rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby library for mocking and stubbing using a syntax like that of JMock, and SchMock"
+HOMEPAGE="http://gofreerange.com/mocha/docs/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ doc? ( dev-ruby/yard )
+ test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+
+ruby_add_rdepend "dev-ruby/metaclass" #metaclass ~> 0.0.1
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '1iload "lib/mocha/version.rb"' Rakefile || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc; then
+ rake examples || die
+ fi
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 test/unit/*
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*.rb || die
+}