summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-05-15 06:33:09 +0000
committerHans de Graaff <graaff@gentoo.org>2012-05-15 06:33:09 +0000
commit67cf20fc86937177ee93e6a53c202c8f1f98e132 (patch)
treed46bc8e5f9d5b42f457151a11ecb927b100e8b93 /dev-ruby/msgpack/msgpack-0.4.7.ebuild
parentVersion bump. (diff)
downloadgentoo-2-67cf20fc86937177ee93e6a53c202c8f1f98e132.tar.gz
gentoo-2-67cf20fc86937177ee93e6a53c202c8f1f98e132.tar.bz2
gentoo-2-67cf20fc86937177ee93e6a53c202c8f1f98e132.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/msgpack/msgpack-0.4.7.ebuild')
-rw-r--r--dev-ruby/msgpack/msgpack-0.4.7.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/msgpack/msgpack-0.4.7.ebuild b/dev-ruby/msgpack/msgpack-0.4.7.ebuild
new file mode 100644
index 000000000000..f6d8be54b7d2
--- /dev/null
+++ b/dev-ruby/msgpack/msgpack-0.4.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/msgpack/msgpack-0.4.7.ebuild,v 1.1 2012/05/15 06:33:09 graaff Exp $
+
+EAPI="3"
+
+# jruby → uses a binary extension
+USE_RUBY="ruby18 ruby19 ree18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Binary-based efficient data interchange format for ruby binding"
+HOMEPAGE="http://msgpack.sourceforge.jp/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die "Configuration of extension failed."
+}
+
+each_ruby_compile() {
+ emake -Cext || die
+
+ mkdir lib || die "Unable to make lib directory."
+ cp ext/msgpack.so lib/ || die "Unable to install msgpack library."
+}
+
+each_ruby_test() {
+ cd test
+ ${RUBY} test_cases.rb || die "tests failed"
+ ${RUBY} test_pack_unpack.rb || die "tests failed"
+ ${RUBY} test_encoding.rb || die "tests failed"
+}