summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-12-25 08:12:29 +0000
committerHans de Graaff <graaff@gentoo.org>2012-12-25 08:12:29 +0000
commit3ae9852e41b22bf80623efeb382c89baa393f08e (patch)
tree8e45396f745c17ee45e7f4a49e89a5febd7a2e8c /dev-ruby/multi_json
parentVersion bump. (diff)
downloadgentoo-2-3ae9852e41b22bf80623efeb382c89baa393f08e.tar.gz
gentoo-2-3ae9852e41b22bf80623efeb382c89baa393f08e.tar.bz2
gentoo-2-3ae9852e41b22bf80623efeb382c89baa393f08e.zip
Version bump.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/multi_json')
-rw-r--r--dev-ruby/multi_json/ChangeLog7
-rw-r--r--dev-ruby/multi_json/multi_json-1.5.0.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-ruby/multi_json/ChangeLog b/dev-ruby/multi_json/ChangeLog
index 356f4f2c73d1..dfc933b87bfa 100644
--- a/dev-ruby/multi_json/ChangeLog
+++ b/dev-ruby/multi_json/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/multi_json
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/ChangeLog,v 1.24 2012/12/01 08:04:43 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/ChangeLog,v 1.25 2012/12/25 08:12:29 graaff Exp $
+
+*multi_json-1.5.0 (25 Dec 2012)
+
+ 25 Dec 2012; Hans de Graaff <graaff@gentoo.org> +multi_json-1.5.0.ebuild:
+ Version bump.
*multi_json-1.4.0 (01 Dec 2012)
diff --git a/dev-ruby/multi_json/multi_json-1.5.0.ebuild b/dev-ruby/multi_json/multi_json-1.5.0.ebuild
new file mode 100644
index 000000000000..70d600de132d
--- /dev/null
+++ b/dev-ruby/multi_json/multi_json-1.5.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_json/multi_json-1.5.0.ebuild,v 1.1 2012/12/25 08:12:29 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="multi_json.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A gem to provide swappable JSON backends"
+HOMEPAGE="http://github.com/intridea/multi_json"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend "|| ( >=dev-ruby/json-1.4 >=dev-ruby/yajl-ruby-0.7 =dev-ruby/activesupport-3* )"
+
+ruby_add_bdepend "doc? ( dev-ruby/rspec:2 )"
+
+ruby_add_bdepend "test? ( dev-ruby/json )"
+
+USE_RUBY="${USE_RUBY/jruby/}" ruby_add_bdepend "test? ( dev-ruby/yajl-ruby )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' Rakefile spec/helper.rb || die "Unable to remove bundler."
+ rm Gemfile || die "Unable to remove bundler Gemfile."
+
+ # Provide version otherwise provided by bundler.
+ sed -i -e "s/#{MultiJson::VERSION}/${PV}/" Rakefile || die
+
+ # Remove unimportant rspec options not supported by rspec 2.6.
+ rm .rspec || die
+
+ # Remove best default spec since we don't package oj yet.
+ sed -i -e '/defaults to the best available gem/,/^ end/ s:^:#:' spec/multi_json_spec.rb || die
+
+ # Contains hardcoded yajl reference with no special case for jruby
+ sed -i -e '/can set adapter for a block/,/^ end/ s:^:#:' spec/multi_json_spec.rb || die
+}
+
+each_ruby_test() {
+ CI=true each_fakegem_test
+}