summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-05-17 15:37:43 +0000
committerHans de Graaff <graaff@gentoo.org>2012-05-17 15:37:43 +0000
commit5dee1df6c784eedbca4b78eb269d71133596033f (patch)
tree46fb81d7a20a24cc8b87cc177c0997f79e0b24b9 /dev-ruby/multi_xml/multi_xml-0.5.1.ebuild
parentkeyword ~amd64-fbsd (diff)
downloadgentoo-2-5dee1df6c784eedbca4b78eb269d71133596033f.tar.gz
gentoo-2-5dee1df6c784eedbca4b78eb269d71133596033f.tar.bz2
gentoo-2-5dee1df6c784eedbca4b78eb269d71133596033f.zip
Version bump.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/multi_xml/multi_xml-0.5.1.ebuild')
-rw-r--r--dev-ruby/multi_xml/multi_xml-0.5.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/multi_xml/multi_xml-0.5.1.ebuild b/dev-ruby/multi_xml/multi_xml-0.5.1.ebuild
new file mode 100644
index 000000000000..ba40d839c833
--- /dev/null
+++ b/dev-ruby/multi_xml/multi_xml-0.5.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/multi_xml/multi_xml-0.5.1.ebuild,v 1.1 2012/05/17 15:37:43 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC="doc:yard"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A generic swappable back-end for XML parsing"
+HOMEPAGE="http://rdoc.info/gems/multi_xml"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )"
+ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5:2 )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+
+ # Remove possible incompatible rspec options.
+ rm .rspec || die
+}
+
+each_ruby_test() {
+ CI=true ${RUBY} -S rspec spec || die
+}