summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-06-22 08:00:04 +0000
committerHans de Graaff <graaff@gentoo.org>2012-06-22 08:00:04 +0000
commit635d6b948c4ea59f4eba59d258d0bfd309291680 (patch)
tree3354ae4447bc76b251a826e51e993f8e7cd5cb11 /dev-ruby/nokogiri
parentmarked x86 per bug 422097 (diff)
downloadgentoo-2-635d6b948c4ea59f4eba59d258d0bfd309291680.tar.gz
gentoo-2-635d6b948c4ea59f4eba59d258d0bfd309291680.tar.bz2
gentoo-2-635d6b948c4ea59f4eba59d258d0bfd309291680.zip
Remove old versions.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/nokogiri')
-rw-r--r--dev-ruby/nokogiri/ChangeLog6
-rw-r--r--dev-ruby/nokogiri/nokogiri-1.5.0-r1.ebuild110
-rw-r--r--dev-ruby/nokogiri/nokogiri-1.5.0-r2.ebuild110
-rw-r--r--dev-ruby/nokogiri/nokogiri-1.5.0.ebuild77
-rw-r--r--dev-ruby/nokogiri/nokogiri-1.5.2.ebuild6
5 files changed, 10 insertions, 299 deletions
diff --git a/dev-ruby/nokogiri/ChangeLog b/dev-ruby/nokogiri/ChangeLog
index 246e1bae1cab..58a2adfa2b40 100644
--- a/dev-ruby/nokogiri/ChangeLog
+++ b/dev-ruby/nokogiri/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/nokogiri
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/ChangeLog,v 1.71 2012/05/11 18:47:41 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/ChangeLog,v 1.72 2012/06/22 08:00:04 graaff Exp $
+
+ 22 Jun 2012; Hans de Graaff <graaff@gentoo.org> -nokogiri-1.5.0.ebuild,
+ -nokogiri-1.5.0-r1.ebuild, -nokogiri-1.5.0-r2.ebuild, nokogiri-1.5.2.ebuild:
+ Remove old versions.
*nokogiri-1.5.2 (11 May 2012)
diff --git a/dev-ruby/nokogiri/nokogiri-1.5.0-r1.ebuild b/dev-ruby/nokogiri/nokogiri-1.5.0-r1.ebuild
deleted file mode 100644
index 0642fe186ff5..000000000000
--- a/dev-ruby/nokogiri/nokogiri-1.5.0-r1.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/nokogiri-1.5.0-r1.ebuild,v 1.1 2011/11/06 11:39:52 graaff Exp $
-
-EAPI=4
-
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc CHANGELOG.ja.rdoc README.rdoc README.ja.rdoc"
-
-inherit ruby-fakegem eutils multilib
-
-DESCRIPTION="Nokogiri is an HTML, XML, SAX, and Reader parser."
-HOMEPAGE="http://nokogiri.rubyforge.org/"
-LICENSE="MIT"
-SRC_URI="https://github.com/tenderlove/nokogiri/tarball/v${PV} -> ${P}.tgz"
-RUBY_S="tenderlove-nokogiri-*"
-
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x64-macos ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-RDEPEND="${RDEPEND}
- dev-libs/libxml2
- dev-libs/libxslt"
-DEPEND="${DEPEND}
- dev-libs/libxml2
- dev-libs/libxslt"
-
-# The tests require _minitest_, not the virtual; what is shipped with
-# Ruby 1.9 is *not* enough, unfortunately
-ruby_add_bdepend "
- dev-ruby/rake-compiler
- dev-ruby/rexical
- dev-ruby/hoe
- dev-ruby/racc
- doc? ( dev-ruby/rdoc )
- test? ( dev-ruby/minitest )"
-
-all_ruby_prepare() {
- sed -i \
- -e '/tasks\/cross_compile/s:^:#:' \
- -e '/:test.*prerequisites/s:^:#:' \
- Rakefile || die
- # Remove the cross compilation options since they interfere with
- # native building.
- sed -i -e 's/cross_compile = true/cross_compile = false/' Rakefile || die
- sed -i -e '/cross_config_options/d' Rakefile || die
-}
-
-each_ruby_prepare() {
- # These test exclusions should be limited to the specific tests, but
- # we are overdue with re-adding jruby so we use the big hammer for now.
- case ${RUBY} in
- *ruby19)
- # Remove test file with failing tests related to encodings.
- rm test/xml/test_node_encoding.rb || die
- ;;
- *jruby)
- # Remove test files with broken tests,
- # https://github.com/tenderlove/nokogiri/issues/496
- rm test/html/sax/test_parser.rb test/html/test_document_encoding.rb test/xml/sax/test_push_parser.rb test/xslt/test_exception_handling.rb || die
- ;;
- *)
- ;;
- esac
-}
-
-each_ruby_configure() {
- case ${RUBY} in
- *jruby)
- ;;
- *)
- ${RUBY} -Cext/${PN} extconf.rb \
- --with-zlib-include="${EPREFIX}"/usr/include \
- --with-zlib-lib="${EPREFIX}"/$(get_libdir) \
- --with-iconv-include="${EPREFIX}"/usr/include \
- --with-iconv-lib="${EPREFIX}"/$(get_libdir) \
- --with-xml2-include="${EPREFIX}"/usr/include/libxml2 \
- --with-xml2-lib="${EPREFIX}"/usr/$(get_libdir) \
- --with-xslt-dir="${EPREFIX}"/usr \
- --with-iconvlib=iconv \
- || die "extconf.rb failed"
- ;;
- esac
-}
-
-each_ruby_compile() {
- case ${RUBY} in
- *jruby)
- ${RUBY} -S rake compile || die
- ;;
- *)
- if ! [[ -f lib/nokogiri/css/tokenizer.rb ]]; then
- ${RUBY} -S rake lib/nokogiri/css/tokenizer.rb || die "rexical failed"
- fi
-
- emake -Cext/${PN} \
- CFLAGS="${CFLAGS} -fPIC" \
- archflag="${LDFLAGS}" || die "make extension failed"
- cp -l ext/${PN}/${PN}$(get_modname) lib/${PN}/ || die
- ;;
- esac
-}
-
-#each_ruby_test() {
-# each_fakegem_test
-#}
diff --git a/dev-ruby/nokogiri/nokogiri-1.5.0-r2.ebuild b/dev-ruby/nokogiri/nokogiri-1.5.0-r2.ebuild
deleted file mode 100644
index 1174e9214b8e..000000000000
--- a/dev-ruby/nokogiri/nokogiri-1.5.0-r2.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/nokogiri-1.5.0-r2.ebuild,v 1.4 2012/03/02 09:51:03 naota Exp $
-
-EAPI=4
-
-USE_RUBY="ruby18 ruby19 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc CHANGELOG.ja.rdoc README.rdoc README.ja.rdoc"
-
-inherit ruby-fakegem eutils multilib
-
-DESCRIPTION="Nokogiri is an HTML, XML, SAX, and Reader parser."
-HOMEPAGE="http://nokogiri.rubyforge.org/"
-LICENSE="MIT"
-SRC_URI="https://github.com/tenderlove/nokogiri/tarball/v${PV} -> ${P}.tgz"
-RUBY_S="tenderlove-nokogiri-*"
-
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-RDEPEND="${RDEPEND}
- dev-libs/libxml2
- dev-libs/libxslt"
-DEPEND="${DEPEND}
- dev-libs/libxml2
- dev-libs/libxslt"
-
-# The tests require _minitest_, not the virtual; what is shipped with
-# Ruby 1.9 is *not* enough, unfortunately
-ruby_add_bdepend "
- dev-ruby/rake-compiler
- dev-ruby/rexical
- dev-ruby/hoe
- dev-ruby/rdoc
- dev-ruby/racc
- test? ( dev-ruby/minitest )"
-
-all_ruby_prepare() {
- sed -i \
- -e '/tasks\/cross_compile/s:^:#:' \
- -e '/:test.*prerequisites/s:^:#:' \
- Rakefile || die
- # Remove the cross compilation options since they interfere with
- # native building.
- sed -i -e 's/cross_compile = true/cross_compile = false/' Rakefile || die
- sed -i -e '/cross_config_options/d' Rakefile || die
-}
-
-each_ruby_prepare() {
- # These test exclusions should be limited to the specific tests, but
- # we are overdue with re-adding jruby so we use the big hammer for now.
- case ${RUBY} in
- *ruby19)
- # Remove test file with failing tests related to encodings.
- rm test/xml/test_node_encoding.rb || die
- ;;
- *jruby)
- # Remove test files with broken tests,
- # https://github.com/tenderlove/nokogiri/issues/496
- rm test/html/sax/test_parser.rb test/html/test_document_encoding.rb test/xml/sax/test_push_parser.rb test/xslt/test_exception_handling.rb || die
- ;;
- *)
- ;;
- esac
-}
-
-each_ruby_configure() {
- case ${RUBY} in
- *jruby)
- ;;
- *)
- ${RUBY} -Cext/${PN} extconf.rb \
- --with-zlib-include="${EPREFIX}"/usr/include \
- --with-zlib-lib="${EPREFIX}"/$(get_libdir) \
- --with-iconv-include="${EPREFIX}"/usr/include \
- --with-iconv-lib="${EPREFIX}"/$(get_libdir) \
- --with-xml2-include="${EPREFIX}"/usr/include/libxml2 \
- --with-xml2-lib="${EPREFIX}"/usr/$(get_libdir) \
- --with-xslt-dir="${EPREFIX}"/usr \
- --with-iconvlib=iconv \
- || die "extconf.rb failed"
- ;;
- esac
-}
-
-each_ruby_compile() {
- case ${RUBY} in
- *jruby)
- ${RUBY} -S rake compile || die
- ;;
- *)
- if ! [[ -f lib/nokogiri/css/tokenizer.rb ]]; then
- ${RUBY} -S rake lib/nokogiri/css/tokenizer.rb || die "rexical failed"
- fi
-
- if ! [[ -f lib/nokogiri/css/parser.rb ]]; then
- ${RUBY} -S rake lib/nokogiri/css/parser.rb || die "racc failed"
- fi
-
- emake -Cext/${PN} \
- CFLAGS="${CFLAGS} -fPIC" \
- archflag="${LDFLAGS}" || die "make extension failed"
- cp -l ext/${PN}/${PN}$(get_modname) lib/${PN}/ || die
- ;;
- esac
-}
diff --git a/dev-ruby/nokogiri/nokogiri-1.5.0.ebuild b/dev-ruby/nokogiri/nokogiri-1.5.0.ebuild
deleted file mode 100644
index e99a2e755cb3..000000000000
--- a/dev-ruby/nokogiri/nokogiri-1.5.0.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/nokogiri-1.5.0.ebuild,v 1.2 2011/08/27 09:43:35 grobian Exp $
-
-EAPI=2
-
-USE_RUBY="ruby18 ruby19 ree18"
-
-RUBY_FAKEGEM_TASK_DOC="docs"
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc CHANGELOG.ja.rdoc README.rdoc README.ja.rdoc"
-
-inherit ruby-fakegem eutils multilib
-
-DESCRIPTION="Nokogiri is an HTML, XML, SAX, and Reader parser."
-HOMEPAGE="http://nokogiri.rubyforge.org/"
-LICENSE="MIT"
-
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
-SLOT="0"
-IUSE=""
-
-RDEPEND="${RDEPEND}
- dev-libs/libxml2
- dev-libs/libxslt"
-DEPEND="${DEPEND}
- dev-libs/libxml2
- dev-libs/libxslt"
-
-# The tests require _minitest_, not the virtual; what is shipped with
-# Ruby 1.9 is *not* enough, unfortunately
-ruby_add_bdepend "
- dev-ruby/rake-compiler
- dev-ruby/rexical
- dev-ruby/hoe
- dev-ruby/racc
- doc? ( dev-ruby/rdoc )
- test? ( dev-ruby/minitest )"
-
-all_ruby_prepare() {
- sed -i \
- -e '/tasks\/cross_compile/s:^:#:' \
- -e '/:test.*prerequisites/s:^:#:' \
- Rakefile || die
- # Remove the cross compilation options since they interfere with
- # native building.
- sed -i -e 's/cross_compile = true/cross_compile = false/' Rakefile || die
- sed -i -e '/cross_config_options/d' Rakefile || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/${PN} extconf.rb \
- --with-zlib-include="${EPREFIX}"/usr/include \
- --with-zlib-lib="${EPREFIX}"/$(get_libdir) \
- --with-iconv-include="${EPREFIX}"/usr/include \
- --with-iconv-lib="${EPREFIX}"/$(get_libdir) \
- --with-xml2-include="${EPREFIX}"/usr/include/libxml2 \
- --with-xml2-lib="${EPREFIX}"/usr/$(get_libdir) \
- --with-xslt-dir="${EPREFIX}"/usr \
- --with-iconvlib=iconv \
- || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- if ! [[ -f lib/nokogiri/css/tokenizer.rb ]]; then
- ${RUBY} -S rake lib/nokogiri/css/tokenizer.rb || die "rexical failed"
- fi
-
- emake -Cext/${PN} \
- CFLAGS="${CFLAGS} -fPIC" \
- archflag="${LDFLAGS}" || die "make extension failed"
- cp -l ext/${PN}/${PN}$(get_modname) lib/${PN}/ || die
-}
-
-each_ruby_test() {
- each_fakegem_test
-}
diff --git a/dev-ruby/nokogiri/nokogiri-1.5.2.ebuild b/dev-ruby/nokogiri/nokogiri-1.5.2.ebuild
index 9cb10d1b99fa..7c2f06496fd7 100644
--- a/dev-ruby/nokogiri/nokogiri-1.5.2.ebuild
+++ b/dev-ruby/nokogiri/nokogiri-1.5.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/nokogiri-1.5.2.ebuild,v 1.1 2012/05/11 18:47:41 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/nokogiri/nokogiri-1.5.2.ebuild,v 1.2 2012/06/22 08:00:04 graaff Exp $
EAPI=4
@@ -79,6 +79,10 @@ each_ruby_configure() {
each_ruby_compile() {
case ${RUBY} in
*jruby)
+ if ! [[ -f lib/nokogiri/css/parser.rb ]]; then
+ ${RUBY} -S rake lib/nokogiri/css/parser.rb || die "racc failed"
+ fi
+
${RUBY} -S rake compile || die
;;
*)