summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-10-05 10:33:57 +0000
committerHans de Graaff <graaff@gentoo.org>2012-10-05 10:33:57 +0000
commit0eed8780073ccd49878c1f784ce6e5041fc1f2ca (patch)
treee47a6a5da9fbf141151a90611520822a12b25466 /dev-ruby/oauth
parentVersion bump. (diff)
downloadgentoo-2-0eed8780073ccd49878c1f784ce6e5041fc1f2ca.tar.gz
gentoo-2-0eed8780073ccd49878c1f784ce6e5041fc1f2ca.tar.bz2
gentoo-2-0eed8780073ccd49878c1f784ce6e5041fc1f2ca.zip
Version bump.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/oauth')
-rw-r--r--dev-ruby/oauth/ChangeLog7
-rw-r--r--dev-ruby/oauth/oauth-0.4.7.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-ruby/oauth/ChangeLog b/dev-ruby/oauth/ChangeLog
index 96e74caffdcb..562ff65253a9 100644
--- a/dev-ruby/oauth/ChangeLog
+++ b/dev-ruby/oauth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/oauth
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/ChangeLog,v 1.19 2012/08/04 14:14:14 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/ChangeLog,v 1.20 2012/10/05 10:33:57 graaff Exp $
+
+*oauth-0.4.7 (05 Oct 2012)
+
+ 05 Oct 2012; Hans de Graaff <graaff@gentoo.org> +oauth-0.4.7.ebuild:
+ Version bump.
04 Aug 2012; Hans de Graaff <graaff@gentoo.org> oauth-0.4.6.ebuild:
Add ruby19. Avoid dependency on old actionpack since we don't have that
diff --git a/dev-ruby/oauth/oauth-0.4.7.ebuild b/dev-ruby/oauth/oauth-0.4.7.ebuild
new file mode 100644
index 000000000000..19c927148e04
--- /dev/null
+++ b/dev-ruby/oauth/oauth-0.4.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/oauth-0.4.7.ebuild,v 1.1 2012/10/05 10:33:57 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="HISTORY README.rdoc TODO"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A RubyGem for implementing both OAuth clients and servers."
+HOMEPAGE="http://oauth.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/mocha
+ dev-ruby/webmock )"
+USE_RUBY="ruby18 ree18" ruby_add_bdepend "test? ( >=dev-ruby/actionpack-2.3.8:2.3 )"
+
+all_ruby_prepare() {
+ # Ensure a consistent test order to avoid loading issues with e.g. rack
+ sed -i -e "s/.rb']/.rb'].sort/" Rakefile || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby18)
+ # Ignore hash ordering test failures
+ sed -i -e '183s:^:#:' -e '224s:^:#:' test/integration/consumer_test.rb || die
+ ;;
+ *rubyee18)
+ # Ignore hash ordering test failures
+ sed -i -e '183s:^:#:' -e '224s:^:#:' test/integration/consumer_test.rb || die
+ ;;
+ *ruby19)
+ # Remove tests depending on rails.
+ rm test/test_action_controller_request_proxy.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}