summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-06-25 21:04:16 +0000
committerHans de Graaff <graaff@gentoo.org>2010-06-25 21:04:16 +0000
commit2032b2d52edd11a1451c1f72c59476873b02a405 (patch)
treee1ec73171853b712f23e64328a5016617913b640 /dev-ruby/oauth
parentStable on amd64 wrt bug #325531 (diff)
downloadgentoo-2-2032b2d52edd11a1451c1f72c59476873b02a405.tar.gz
gentoo-2-2032b2d52edd11a1451c1f72c59476873b02a405.tar.bz2
gentoo-2-2032b2d52edd11a1451c1f72c59476873b02a405.zip
Version bump.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/oauth')
-rw-r--r--dev-ruby/oauth/ChangeLog8
-rw-r--r--dev-ruby/oauth/files/oauth-0.4.1-optional-tests.patch119
-rw-r--r--dev-ruby/oauth/oauth-0.4.1.ebuild24
3 files changed, 150 insertions, 1 deletions
diff --git a/dev-ruby/oauth/ChangeLog b/dev-ruby/oauth/ChangeLog
index 9722b850c71a..586a20ec5f89 100644
--- a/dev-ruby/oauth/ChangeLog
+++ b/dev-ruby/oauth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/oauth
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/ChangeLog,v 1.8 2010/05/22 15:32:19 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/ChangeLog,v 1.9 2010/06/25 21:04:16 graaff Exp $
+
+*oauth-0.4.1 (25 Jun 2010)
+
+ 25 Jun 2010; Hans de Graaff <graaff@gentoo.org> +oauth-0.4.1.ebuild,
+ +files/oauth-0.4.1-optional-tests.patch:
+ Version bump.
22 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
oauth-0.3.6-r1.ebuild:
diff --git a/dev-ruby/oauth/files/oauth-0.4.1-optional-tests.patch b/dev-ruby/oauth/files/oauth-0.4.1-optional-tests.patch
new file mode 100644
index 000000000000..175e6090abc1
--- /dev/null
+++ b/dev-ruby/oauth/files/oauth-0.4.1-optional-tests.patch
@@ -0,0 +1,119 @@
+Fix loading (or rather, not loading) of optional tests. Submitted upstream.
+http://github.com/graaff/oauth-ruby/commit/de7fd4a02edf236e74f4bb84eeafb02597500d79
+
+diff --git a/test/test_curb_request_proxy.rb b/test/test_curb_request_proxy.rb
+index ae5cb50..af15435 100644
+--- a/test/test_curb_request_proxy.rb
++++ b/test/test_curb_request_proxy.rb
+@@ -1,12 +1,9 @@
+ require 'test_helper'
+
+ begin
+- require 'oauth/request_proxy/curb_request'
+- require 'curb'
+-rescue LoadError => e
+- warn "! problems loading curb, skipping these tests: #{e}"
+- return
+-end
++
++require 'oauth/request_proxy/curb_request'
++require 'curb'
+
+
+ class CurbRequestProxyTest < Test::Unit::TestCase
+@@ -73,4 +70,8 @@ class CurbRequestProxyTest < Test::Unit::TestCase
+ assert_equal expected_parameters, request_proxy.parameters_for_signature
+ assert_equal 'http://example.com/test', request_proxy.normalized_uri
+ end
+-end
+\ No newline at end of file
++end
++
++rescue LoadError => e
++ warn "! problems loading curb, skipping these tests: #{e}"
++end
+diff --git a/test/test_em_http_client.rb b/test/test_em_http_client.rb
+index 8b8642f..c3f97e5 100644
+--- a/test/test_em_http_client.rb
++++ b/test/test_em_http_client.rb
+@@ -1,10 +1,7 @@
+ require 'test_helper'
+ begin
+- require 'oauth/client/em_http'
+-rescue LoadError => e
+- warn "! problem loading em-http, skipping these tests: #{e}"
+- return
+-end
++
++require 'oauth/client/em_http'
+
+ class EmHttpClientTest < Test::Unit::TestCase
+
+@@ -77,3 +74,7 @@ class EmHttpClientTest < Test::Unit::TestCase
+ end
+
+ end
++
++rescue LoadError => e
++ warn "! problem loading em-http, skipping these tests: #{e}"
++end
+diff --git a/test/test_em_http_request_proxy.rb b/test/test_em_http_request_proxy.rb
+index 055a95a..f0200a7 100644
+--- a/test/test_em_http_request_proxy.rb
++++ b/test/test_em_http_request_proxy.rb
+@@ -1,12 +1,9 @@
+ require 'test_helper'
+
+ begin
+- require 'em-http'
+- require 'oauth/request_proxy/em_http_request'
+-rescue LoadError => e
+- warn "! problem loading em-http, skipping these tests: #{e}"
+- return
+-end
++
++require 'em-http'
++require 'oauth/request_proxy/em_http_request'
+
+
+ class EmHttpRequestProxyTest < Test::Unit::TestCase
+@@ -111,4 +108,8 @@ class EmHttpRequestProxyTest < Test::Unit::TestCase
+ OAuth::RequestProxy.proxy(create_client(opts), arguments)
+ end
+
+-end
+\ No newline at end of file
++end
++
++rescue LoadError => e
++ warn "! problem loading em-http, skipping these tests: #{e}"
++end
+diff --git a/test/test_typhoeus_request_proxy.rb b/test/test_typhoeus_request_proxy.rb
+index 4044604..c54ad8e 100644
+--- a/test/test_typhoeus_request_proxy.rb
++++ b/test/test_typhoeus_request_proxy.rb
+@@ -1,13 +1,9 @@
+ require 'test_helper'
+
+ begin
+- require 'oauth/request_proxy/typhoeus_request'
+- require 'typhoeus'
+-rescue LoadError => e
+- warn "! problem loading typhoeus, skipping these tests: #{e}"
+- return
+-end
+
++require 'oauth/request_proxy/typhoeus_request'
++require 'typhoeus'
+
+ class TyphoeusRequestProxyTest < Test::Unit::TestCase
+
+@@ -78,3 +74,8 @@ class TyphoeusRequestProxyTest < Test::Unit::TestCase
+ assert_equal 'POST', request_proxy.method
+ end
+ end
++
++rescue LoadError => e
++ warn "! problem loading typhoeus, skipping these tests: #{e}"
++end
++
diff --git a/dev-ruby/oauth/oauth-0.4.1.ebuild b/dev-ruby/oauth/oauth-0.4.1.ebuild
new file mode 100644
index 000000000000..c0ef92fbd6a6
--- /dev/null
+++ b/dev-ruby/oauth/oauth-0.4.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth/oauth-0.4.1.ebuild,v 1.1 2010/06/25 21:04:16 graaff Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="HISTORY README.rdoc TODO"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A RubyGem for implementing both OAuth clients and servers."
+HOMEPAGE="http://oauth.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RUBY_PATCHES=( "${P}-optional-tests.patch" )
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit dev-ruby/actionpack dev-ruby/mocha )"