summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2012-04-29 15:26:43 +0000
committerBenedikt Boehm <hollow@gentoo.org>2012-04-29 15:26:43 +0000
commit40d5801a6eaf1082ceeac1b1d66f9abf586f4f56 (patch)
tree673a865ab83c6110d4a510fa14e8cf93d11ba059 /dev-ruby/ohai/ohai-0.6.12.ebuild
parentx86 stable, bug #410611 (diff)
downloadgentoo-2-40d5801a6eaf1082ceeac1b1d66f9abf586f4f56.tar.gz
gentoo-2-40d5801a6eaf1082ceeac1b1d66f9abf586f4f56.tar.bz2
gentoo-2-40d5801a6eaf1082ceeac1b1d66f9abf586f4f56.zip
bump version for improved interface detection via iproute2
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ohai/ohai-0.6.12.ebuild')
-rw-r--r--dev-ruby/ohai/ohai-0.6.12.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/ohai/ohai-0.6.12.ebuild b/dev-ruby/ohai/ohai-0.6.12.ebuild
new file mode 100644
index 000000000000..5b5b67e7d846
--- /dev/null
+++ b/dev-ruby/ohai/ohai-0.6.12.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ohai/ohai-0.6.12.ebuild,v 1.1 2012/04/29 15:26:43 hollow Exp $
+
+EAPI=4
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.rdoc"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ohai profiles your system and emits JSON"
+HOMEPAGE="http://wiki.opscode.com/display/chef/Ohai"
+SRC_URI="https://github.com/opscode/${PN}/tarball/${PV} -> ${P}.tgz"
+RUBY_S="opscode-${PN}-*"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:2 dev-ruby/sigar )"
+
+ruby_add_rdepend "
+ dev-ruby/ipaddress
+ dev-ruby/yajl-ruby
+ dev-ruby/mixlib-cli
+ dev-ruby/mixlib-config
+ dev-ruby/mixlib-log
+ >=dev-ruby/systemu-2.2.0"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ # Be more lenient to work with versions of systemu that we have in
+ # the tree.
+ sed -i -e 's/~> 2.2.0/>= 2.2.0/' ohai.gemspec || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman docs/man/man1/ohai.1
+}