summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-07-24 06:04:09 +0000
committerHans de Graaff <graaff@gentoo.org>2010-07-24 06:04:09 +0000
commit27062b93ab3d4699eaf71ecf43040b900f8d86d7 (patch)
treec494fb4f94dcede2a09e0c800a47ea8cdbd4b817 /dev-ruby/patron
parentVersion bump #329455 by Petr Pisar. (diff)
downloadgentoo-2-27062b93ab3d4699eaf71ecf43040b900f8d86d7.tar.gz
gentoo-2-27062b93ab3d4699eaf71ecf43040b900f8d86d7.tar.bz2
gentoo-2-27062b93ab3d4699eaf71ecf43040b900f8d86d7.zip
Initial import. New dependency of dev-ruby/webmock.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/patron')
-rw-r--r--dev-ruby/patron/ChangeLog10
-rw-r--r--dev-ruby/patron/metadata.xml5
-rw-r--r--dev-ruby/patron/patron-0.4.6.ebuild37
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-ruby/patron/ChangeLog b/dev-ruby/patron/ChangeLog
new file mode 100644
index 000000000000..e056ccaa5180
--- /dev/null
+++ b/dev-ruby/patron/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ruby/patron
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/ChangeLog,v 1.1 2010/07/24 06:04:09 graaff Exp $
+
+*patron-0.4.6 (24 Jul 2010)
+
+ 24 Jul 2010; Hans de Graaff <graaff@gentoo.org> +patron-0.4.6.ebuild,
+ +metadata.xml:
+ Initial import. New dependency of dev-ruby/webmock.
+
diff --git a/dev-ruby/patron/metadata.xml b/dev-ruby/patron/metadata.xml
new file mode 100644
index 000000000000..852136183369
--- /dev/null
+++ b/dev-ruby/patron/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>
diff --git a/dev-ruby/patron/patron-0.4.6.ebuild b/dev-ruby/patron/patron-0.4.6.ebuild
new file mode 100644
index 000000000000..290ec81f22f6
--- /dev/null
+++ b/dev-ruby/patron/patron-0.4.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/patron-0.4.6.ebuild,v 1.1 2010/07/24 06:04:09 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl."
+HOMEPAGE="http://toland.github.com/patron/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/jeweler )"
+#ruby_add_bdepend "test? ( dev-ruby/jeweler dev-ruby/rspec )"
+
+DEPEND="${DEPEND} net-misc/curl"
+RDEPEND="${RDEPEND} net-misc/curl"
+
+# Tests require a live web service that is not included in the distribution.
+RESTRICT="test"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/patron extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/patron || die
+ cp ext/patron/session_ext$(get_modname) lib/ || die "Unable to cp shared object file"
+}