summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-10-30 03:39:40 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-10-30 03:39:40 +0000
commit336e20d6e286a8ff3153ddfb542509ff9ea78697 (patch)
tree8c07d3b991b6f9424f9e08e88ab385a262164feb /dev-ruby/patron
parentAdd ruby20 target. (diff)
downloadgentoo-2-336e20d6e286a8ff3153ddfb542509ff9ea78697.tar.gz
gentoo-2-336e20d6e286a8ff3153ddfb542509ff9ea78697.tar.bz2
gentoo-2-336e20d6e286a8ff3153ddfb542509ff9ea78697.zip
Add ruby20 target.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/patron')
-rw-r--r--dev-ruby/patron/ChangeLog7
-rw-r--r--dev-ruby/patron/patron-0.4.18-r1.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-ruby/patron/ChangeLog b/dev-ruby/patron/ChangeLog
index 3d4ee200278d..bdf09ce3904e 100644
--- a/dev-ruby/patron/ChangeLog
+++ b/dev-ruby/patron/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/patron
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/ChangeLog,v 1.25 2013/01/01 09:04:20 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/ChangeLog,v 1.26 2013/10/30 03:39:40 mrueg Exp $
+
+*patron-0.4.18-r1 (30 Oct 2013)
+
+ 30 Oct 2013; Manuel Rüger <mrueg@gentoo.org> +patron-0.4.18-r1.ebuild:
+ Add ruby20 target.
01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> patron-0.4.18.ebuild:
Stable for x86, wrt bug #448672
diff --git a/dev-ruby/patron/patron-0.4.18-r1.ebuild b/dev-ruby/patron/patron-0.4.18-r1.ebuild
new file mode 100644
index 000000000000..1186e086a561
--- /dev/null
+++ b/dev-ruby/patron/patron-0.4.18-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/patron/patron-0.4.18-r1.ebuild,v 1.1 2013/10/30 03:39:39 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_EXTRADOC="README.txt"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Patron is a Ruby HTTP client library based on libcurl."
+HOMEPAGE="http://toland.github.com/patron/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+#ruby_add_bdepend "test? ( dev-ruby/rspec:2 )"
+
+DEPEND+=" net-misc/curl"
+RDEPEND+=" net-misc/curl"
+
+# Tests require a live web service that is not included in the distribution.
+RESTRICT="test"
+
+each_ruby_configure() {
+ ${RUBY} -Cext/patron extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/patron V=1
+ cp ext/patron/session_ext$(get_modname) lib/patron/ || die "Unable to cp shared object file"
+}