summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-08-30 11:31:13 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-08-30 11:31:13 +0000
commit411d97039c47f525e561fc39dd9ccbe1e7c535c2 (patch)
tree49febc4ab714d422a38731d12a5a6580c92b753e /dev-ruby/pkg-config
parentStable for amd64 wrt bug #511620 (diff)
downloadgentoo-2-411d97039c47f525e561fc39dd9ccbe1e7c535c2.tar.gz
gentoo-2-411d97039c47f525e561fc39dd9ccbe1e7c535c2.tar.bz2
gentoo-2-411d97039c47f525e561fc39dd9ccbe1e7c535c2.zip
Move ruby21 to -r1. Stable for amd64. See bug #521316.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/pkg-config')
-rw-r--r--dev-ruby/pkg-config/ChangeLog8
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.1.5-r1.ebuild34
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.1.5.ebuild8
3 files changed, 44 insertions, 6 deletions
diff --git a/dev-ruby/pkg-config/ChangeLog b/dev-ruby/pkg-config/ChangeLog
index 976798f1f20b..591ae8d8033e 100644
--- a/dev-ruby/pkg-config/ChangeLog
+++ b/dev-ruby/pkg-config/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/pkg-config
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pkg-config/ChangeLog,v 1.26 2014/08/16 14:13:03 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pkg-config/ChangeLog,v 1.27 2014/08/30 11:31:13 mrueg Exp $
+
+*pkg-config-1.1.5-r1 (30 Aug 2014)
+
+ 30 Aug 2014; Manuel Rüger <mrueg@gentoo.org> +pkg-config-1.1.5-r1.ebuild,
+ pkg-config-1.1.5.ebuild:
+ Move ruby21 to -r1. Stable for amd64. See bug #521316.
16 Aug 2014; Manuel Rüger <mrueg@gentoo.org> pkg-config-1.1.5.ebuild:
Remove unneeded dependency.
diff --git a/dev-ruby/pkg-config/pkg-config-1.1.5-r1.ebuild b/dev-ruby/pkg-config/pkg-config-1.1.5-r1.ebuild
new file mode 100644
index 000000000000..e1ecfb58a4e6
--- /dev/null
+++ b/dev-ruby/pkg-config/pkg-config-1.1.5-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pkg-config/pkg-config-1.1.5-r1.ebuild,v 1.1 2014/08/30 11:31:13 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pkg-config implementation by Ruby"
+HOMEPAGE="https://github.com/rcairo/pkg-config"
+LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+# this is used for testing
+DEPEND+=" test? ( x11-libs/cairo )"
+
+all_ruby_prepare() {
+# drop failing tests
+ sed -i -e "/test_cflags/,/end/d"\
+ -e "/test_cflags_only_I/,/end/d" test/test_pkg_config.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_${PN/-/_}.rb
+}
diff --git a/dev-ruby/pkg-config/pkg-config-1.1.5.ebuild b/dev-ruby/pkg-config/pkg-config-1.1.5.ebuild
index d832b404da1c..d40bcb54c4ef 100644
--- a/dev-ruby/pkg-config/pkg-config-1.1.5.ebuild
+++ b/dev-ruby/pkg-config/pkg-config-1.1.5.ebuild
@@ -1,23 +1,21 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pkg-config/pkg-config-1.1.5.ebuild,v 1.4 2014/08/16 14:13:03 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pkg-config/pkg-config-1.1.5.ebuild,v 1.5 2014/08/30 11:31:13 mrueg Exp $
EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21"
+USE_RUBY="ruby19 ruby20"
RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_RECIPE_TEST="none"
-
inherit ruby-fakegem
DESCRIPTION="A pkg-config implementation by Ruby"
HOMEPAGE="https://github.com/rcairo/pkg-config"
LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+KEYWORDS="amd64 ~ppc ~ppc64 ~x86"
SLOT="0"
IUSE="test"