summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-06-27 17:47:56 +0000
committerHans de Graaff <graaff@gentoo.org>2010-06-27 17:47:56 +0000
commita1fe547254fc859a7f06434b4d65a1d5e4b29b59 (patch)
tree4334c09c5b327bd6349e9d0e90e8243107a4221f /dev-ruby/podcast/podcast-0.0.4-r1.ebuild
parentx86 stable, bug 322791 (diff)
downloadgentoo-2-a1fe547254fc859a7f06434b4d65a1d5e4b29b59.tar.gz
gentoo-2-a1fe547254fc859a7f06434b4d65a1d5e4b29b59.tar.bz2
gentoo-2-a1fe547254fc859a7f06434b4d65a1d5e4b29b59.zip
Convert to ruby-fakegem.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/podcast/podcast-0.0.4-r1.ebuild')
-rw-r--r--dev-ruby/podcast/podcast-0.0.4-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/podcast/podcast-0.0.4-r1.ebuild b/dev-ruby/podcast/podcast-0.0.4-r1.ebuild
new file mode 100644
index 000000000000..65736b253c23
--- /dev/null
+++ b/dev-ruby/podcast/podcast-0.0.4-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/podcast/podcast-0.0.4-r1.ebuild,v 1.1 2010/06/27 17:47:56 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pure Ruby library for generating podcasts from mp3 files"
+HOMEPAGE="http://podcast.rubyforge.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+
+IUSE="test"
+
+ruby_add_bdepend "test? ( virtual/ruby-test-unit )"
+ruby_add_rdepend "dev-ruby/ruby-mp3info"
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/ts_podcast.rb || die "Tests failed."
+}