summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-02-09 07:41:50 +0000
committerHans de Graaff <graaff@gentoo.org>2013-02-09 07:41:50 +0000
commit26a7dec13e113ab348065232a3a2aa506b9cd6d0 (patch)
tree41930f999f7b78bbb6e3038657e539e27feb7201 /dev-ruby/rack
parentDrop cross-compiling hacks since upstream handles it now #284762. (diff)
downloadgentoo-2-26a7dec13e113ab348065232a3a2aa506b9cd6d0.tar.gz
gentoo-2-26a7dec13e113ab348065232a3a2aa506b9cd6d0.tar.bz2
gentoo-2-26a7dec13e113ab348065232a3a2aa506b9cd6d0.zip
Version bumps for security bug 456176.
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rack')
-rw-r--r--dev-ruby/rack/ChangeLog11
-rw-r--r--dev-ruby/rack/rack-1.1.6.ebuild54
-rw-r--r--dev-ruby/rack/rack-1.2.8.ebuild74
-rw-r--r--dev-ruby/rack/rack-1.3.10.ebuild51
-rw-r--r--dev-ruby/rack/rack-1.4.5.ebuild42
5 files changed, 231 insertions, 1 deletions
diff --git a/dev-ruby/rack/ChangeLog b/dev-ruby/rack/ChangeLog
index c54718a10a81..3488ee59350c 100644
--- a/dev-ruby/rack/ChangeLog
+++ b/dev-ruby/rack/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-ruby/rack
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/ChangeLog,v 1.105 2013/02/09 07:27:33 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/ChangeLog,v 1.106 2013/02/09 07:41:50 graaff Exp $
+
+*rack-1.4.5 (09 Feb 2013)
+*rack-1.3.10 (09 Feb 2013)
+*rack-1.2.8 (09 Feb 2013)
+*rack-1.1.6 (09 Feb 2013)
+
+ 09 Feb 2013; Hans de Graaff <graaff@gentoo.org> +rack-1.1.6.ebuild,
+ +rack-1.2.8.ebuild, +rack-1.3.10.ebuild, +rack-1.4.5.ebuild:
+ Version bumps for security bug 456176.
09 Feb 2013; Hans de Graaff <graaff@gentoo.org> -rack-1.1.3-r1.ebuild,
-rack-1.1.4.ebuild, -rack-1.2.5.ebuild, -rack-1.2.6.ebuild,
diff --git a/dev-ruby/rack/rack-1.1.6.ebuild b/dev-ruby/rack/rack-1.1.6.ebuild
new file mode 100644
index 000000000000..da90f2638e81
--- /dev/null
+++ b/dev-ruby/rack/rack-1.1.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.1.6.ebuild,v 1.1 2013/02/09 07:41:50 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A modular Ruby webserver interface"
+HOMEPAGE="http://rubyforge.org/projects/rack"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# The gem has automagic dependencies over mongrel, ruby-openid,
+# memcache-client, thin, mongrel and camping; not sure if we should
+# make them dependencies at all.
+ruby_add_bdepend "test? ( dev-ruby/test-spec )"
+
+all_ruby_prepare() {
+ # Avoid tests depending on now randomized hash ordering.
+ sed -i -e '/foobarfoo/ s:^:#:' test/spec_rack_response.rb || die
+ sed -i -e '/should build query strings correctly/,/end/ s:^:#:' test/spec_rack_utils.rb || die
+ sed -i -e '/should build nested query strings correctly/,/end/ s:^:#:' test/spec_rack_utils.rb || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *jruby)
+ # Avoid broken specs. Already broken in 1.1.3 and not likely
+ # to be fixed anymore due to the age of this version.
+ rm test/spec_rack_mock.rb test/spec_rack_runtime.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ # Since the Rakefile calls specrb directly rather than loading it, we
+ # cannot use it to launch the tests or only the currently-selected
+ # RUBY interpreter will be tested.
+ ${RUBY} -S specrb -Ilib:test -w -a \
+ -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|rackup)' \
+ || die "test failed for ${RUBY}"
+}
diff --git a/dev-ruby/rack/rack-1.2.8.ebuild b/dev-ruby/rack/rack-1.2.8.ebuild
new file mode 100644
index 000000000000..418d01d071ea
--- /dev/null
+++ b/dev-ruby/rack/rack-1.2.8.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.2.8.ebuild,v 1.1 2013/02/09 07:41:50 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog KNOWN-ISSUES README SPEC"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="A modular Ruby webserver interface"
+HOMEPAGE="http://rubyforge.org/projects/rack"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+# The gem has automagic dependencies over mongrel, ruby-openid,
+# memcache-client, thin, mongrel and camping; not sure if we should
+# make them dependencies at all. We do add the fcgi dependency because
+# that spec isn't optional.
+ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/fcgi )"
+
+# Block against versions in older slots that also try to install a binary.
+RDEPEND="${RDEPEND} !<dev-ruby/rack-1.1.3-r1"
+
+#USE_RUBY=ruby19 \
+# ruby_add_bdepend "ruby_targets_ruby19 test" '=dev-ruby/test-unit-1*'
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.1-gentoo.patch
+
+ # Add missing require for Mutex use. This may show up in the tests
+ # depending on load order.
+ sed -i -e '1 irequire "thread"' lib/rack/lock.rb || die
+
+ # Avoid tests depending on now randomized hash ordering.
+ sed -i -e '/foobarfoo/ s:^:#:' test/spec_response.rb || die
+ sed -i -e '/build query strings correctly/,/end/ s:^:#:' test/spec_utils.rb || die
+ sed -i -e '/build nested query strings correctly/,/end/ s:^:#:' test/spec_utils.rb || die
+}
+
+each_ruby_prepare() {
+ case ${RUBY} in
+ *ruby19)
+ # Avoid failing encoding-related specs, most likely due to
+ # changes in handling of encodings in newer ruby 19
+ # versions.
+ sed -i -e '/escape non-UTF8 strings/,/end/ s:^:#:' test/spec_utils.rb || die
+ sed -i -e '/escape html entities in unicode strings/,/end/ s:^:#:' test/spec_utils.rb || die
+ sed -i -e '/escape html entities even on MRI/,/^ end/ s:^:#:' test/spec_utils.rb || die
+ sed -i -e '/accept params and build multipart encoded params/,/^ end/ s:^:#:' test/spec_mock.rb || die
+ ;;
+ *)
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ # Since the Rakefile calls specrb directly rather than loading it, we
+ # cannot use it to launch the tests or only the currently-selected
+ # RUBY interpreter will be tested.
+ ${RUBY} -S bacon -Ilib -w -a \
+ -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|rackup)' \
+ || die "test failed for ${RUBY}"
+}
diff --git a/dev-ruby/rack/rack-1.3.10.ebuild b/dev-ruby/rack/rack-1.3.10.ebuild
new file mode 100644
index 000000000000..c2e0d5a869a6
--- /dev/null
+++ b/dev-ruby/rack/rack-1.3.10.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.3.10.ebuild,v 1.1 2013/02/09 07:41:50 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog KNOWN-ISSUES README.rdoc SPEC"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="A modular Ruby webserver interface"
+HOMEPAGE="http://rubyforge.org/projects/rack"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+# The gem has automagic dependencies over mongrel, ruby-openid,
+# memcache-client, thin, mongrel and camping; not sure if we should
+# make them dependencies at all. We do add the fcgi dependency because
+# that spec isn't optional.
+ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/fcgi )"
+
+# Block against versions in older slots that also try to install a binary.
+RDEPEND="${RDEPEND} !<dev-ruby/rack-1.1.3-r1:0 !<dev-ruby/rack-1.2.5:1.2"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.1-gentoo.patch
+
+ # Avoid tests depending on now randomized hash ordering.
+ sed -i -e '/foobarfoo/ s:^:#:' test/spec_response.rb || die
+ sed -i -e '/build query strings correctly/,/end/ s:^:#:' test/spec_utils.rb || die
+ sed -i -e '/build nested query strings correctly/,/end/ s:^:#:' test/spec_utils.rb || die
+}
+
+each_ruby_test() {
+ # Since the Rakefile calls specrb directly rather than loading it, we
+ # cannot use it to launch the tests or only the currently-selected
+ # RUBY interpreter will be tested.
+ ${RUBY} -S bacon -Ilib -w -a \
+ -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
+ || die "test failed for ${RUBY}"
+}
diff --git a/dev-ruby/rack/rack-1.4.5.ebuild b/dev-ruby/rack/rack-1.4.5.ebuild
new file mode 100644
index 000000000000..b05d4541aed0
--- /dev/null
+++ b/dev-ruby/rack/rack-1.4.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.4.5.ebuild,v 1.1 2013/02/09 07:41:50 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="ChangeLog KNOWN-ISSUES README.rdoc SPEC"
+
+inherit ruby-fakegem eutils versionator
+
+DESCRIPTION="A modular Ruby webserver interface"
+HOMEPAGE="http://rack.github.com/"
+SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RUBY_PATCHES=( ${PN}-1.2.1-gentoo.patch )
+
+ruby_add_rdepend "virtual/ruby-ssl"
+
+# The gem has automagic dependencies over mongrel, ruby-openid,
+# memcache-client, thin, mongrel and camping; not sure if we should
+# make them dependencies at all. We do add the fcgi dependency because
+# that spec isn't optional.
+ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/fcgi )"
+
+# Block against versions in older slots that also try to install a binary.
+RDEPEND="${RDEPEND} !<dev-ruby/rack-1.1.3-r1:0 !<dev-ruby/rack-1.2.5:1.2 !<dev-ruby/rack-1.3.6-r1:1.3"
+
+each_ruby_test() {
+ # Since the Rakefile calls specrb directly rather than loading it, we
+ # cannot use it to launch the tests or only the currently-selected
+ # RUBY interpreter will be tested.
+ ${RUBY} -S bacon -Ilib -w -a \
+ -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
+ || die "test failed for ${RUBY}"
+}