summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-04-13 09:44:35 +0000
committerHans de Graaff <graaff@gentoo.org>2013-04-13 09:44:35 +0000
commita50b73e3f8b55623b3b07b35f79607cd19c8a2f0 (patch)
treee53fb07a066a68d1578f256cc7180d7d22207fb2 /dev-ruby/rack
parentInitial commit, wrt bug #459732. Thanks to <warmcharm AT yandex.ru> for initi... (diff)
downloadgentoo-2-a50b73e3f8b55623b3b07b35f79607cd19c8a2f0.tar.gz
gentoo-2-a50b73e3f8b55623b3b07b35f79607cd19c8a2f0.tar.bz2
gentoo-2-a50b73e3f8b55623b3b07b35f79607cd19c8a2f0.zip
Remove vulnerable versions.
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/rack')
-rw-r--r--dev-ruby/rack/ChangeLog6
-rw-r--r--dev-ruby/rack/rack-1.1.5.ebuild54
-rw-r--r--dev-ruby/rack/rack-1.2.7.ebuild74
-rw-r--r--dev-ruby/rack/rack-1.3.9.ebuild51
-rw-r--r--dev-ruby/rack/rack-1.4.4.ebuild42
5 files changed, 5 insertions, 222 deletions
diff --git a/dev-ruby/rack/ChangeLog b/dev-ruby/rack/ChangeLog
index 2160bc92980b..e5d1eba0ab8f 100644
--- a/dev-ruby/rack/ChangeLog
+++ b/dev-ruby/rack/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/rack
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/ChangeLog,v 1.111 2013/02/24 17:35:41 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/ChangeLog,v 1.112 2013/04/13 09:44:35 graaff Exp $
+
+ 13 Apr 2013; Hans de Graaff <graaff@gentoo.org> -rack-1.1.5.ebuild,
+ -rack-1.2.7.ebuild, -rack-1.3.9.ebuild, -rack-1.4.4.ebuild:
+ Remove vulnerable versions.
24 Feb 2013; Agostino Sarubbo <ago@gentoo.org> rack-1.1.6.ebuild,
rack-1.2.8.ebuild, rack-1.3.10.ebuild, rack-1.4.5.ebuild:
diff --git a/dev-ruby/rack/rack-1.1.5.ebuild b/dev-ruby/rack/rack-1.1.5.ebuild
deleted file mode 100644
index 99fe33add973..000000000000
--- a/dev-ruby/rack/rack-1.1.5.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.1.5.ebuild,v 1.6 2013/01/21 14:09:52 ago Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ree18 jruby"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem eutils
-
-DESCRIPTION="A modular Ruby webserver interface"
-HOMEPAGE="http://rubyforge.org/projects/rack"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-# The gem has automagic dependencies over mongrel, ruby-openid,
-# memcache-client, thin, mongrel and camping; not sure if we should
-# make them dependencies at all.
-ruby_add_bdepend "test? ( dev-ruby/test-spec )"
-
-all_ruby_prepare() {
- # Avoid tests depending on now randomized hash ordering.
- sed -i -e '/foobarfoo/ s:^:#:' test/spec_rack_response.rb || die
- sed -i -e '/should build query strings correctly/,/end/ s:^:#:' test/spec_rack_utils.rb || die
- sed -i -e '/should build nested query strings correctly/,/end/ s:^:#:' test/spec_rack_utils.rb || die
-}
-
-each_ruby_prepare() {
- case ${RUBY} in
- *jruby)
- # Avoid broken specs. Already broken in 1.1.3 and not likely
- # to be fixed anymore due to the age of this version.
- rm test/spec_rack_mock.rb test/spec_rack_runtime.rb || die
- ;;
- *)
- ;;
- esac
-}
-
-each_ruby_test() {
- # Since the Rakefile calls specrb directly rather than loading it, we
- # cannot use it to launch the tests or only the currently-selected
- # RUBY interpreter will be tested.
- ${RUBY} -S specrb -Ilib:test -w -a \
- -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|rackup)' \
- || die "test failed for ${RUBY}"
-}
diff --git a/dev-ruby/rack/rack-1.2.7.ebuild b/dev-ruby/rack/rack-1.2.7.ebuild
deleted file mode 100644
index ee7bdecff01f..000000000000
--- a/dev-ruby/rack/rack-1.2.7.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.2.7.ebuild,v 1.5 2013/01/21 14:09:52 ago Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="ChangeLog KNOWN-ISSUES README SPEC"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem eutils versionator
-
-DESCRIPTION="A modular Ruby webserver interface"
-HOMEPAGE="http://rubyforge.org/projects/rack"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend "virtual/ruby-ssl"
-
-# The gem has automagic dependencies over mongrel, ruby-openid,
-# memcache-client, thin, mongrel and camping; not sure if we should
-# make them dependencies at all. We do add the fcgi dependency because
-# that spec isn't optional.
-ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/fcgi )"
-
-# Block against versions in older slots that also try to install a binary.
-RDEPEND="${RDEPEND} !<dev-ruby/rack-1.1.3-r1"
-
-#USE_RUBY=ruby19 \
-# ruby_add_bdepend "ruby_targets_ruby19 test" '=dev-ruby/test-unit-1*'
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${PN}-1.2.1-gentoo.patch
-
- # Add missing require for Mutex use. This may show up in the tests
- # depending on load order.
- sed -i -e '1 irequire "thread"' lib/rack/lock.rb || die
-
- # Avoid tests depending on now randomized hash ordering.
- sed -i -e '/foobarfoo/ s:^:#:' test/spec_response.rb || die
- sed -i -e '/build query strings correctly/,/end/ s:^:#:' test/spec_utils.rb || die
- sed -i -e '/build nested query strings correctly/,/end/ s:^:#:' test/spec_utils.rb || die
-}
-
-each_ruby_prepare() {
- case ${RUBY} in
- *ruby19)
- # Avoid failing encoding-related specs, most likely due to
- # changes in handling of encodings in newer ruby 19
- # versions.
- sed -i -e '/escape non-UTF8 strings/,/end/ s:^:#:' test/spec_utils.rb || die
- sed -i -e '/escape html entities in unicode strings/,/end/ s:^:#:' test/spec_utils.rb || die
- sed -i -e '/escape html entities even on MRI/,/^ end/ s:^:#:' test/spec_utils.rb || die
- sed -i -e '/accept params and build multipart encoded params/,/^ end/ s:^:#:' test/spec_mock.rb || die
- ;;
- *)
- ;;
- esac
-}
-
-each_ruby_test() {
- # Since the Rakefile calls specrb directly rather than loading it, we
- # cannot use it to launch the tests or only the currently-selected
- # RUBY interpreter will be tested.
- ${RUBY} -S bacon -Ilib -w -a \
- -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|rackup)' \
- || die "test failed for ${RUBY}"
-}
diff --git a/dev-ruby/rack/rack-1.3.9.ebuild b/dev-ruby/rack/rack-1.3.9.ebuild
deleted file mode 100644
index b7ee559d0189..000000000000
--- a/dev-ruby/rack/rack-1.3.9.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.3.9.ebuild,v 1.5 2013/01/21 14:09:52 ago Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="ChangeLog KNOWN-ISSUES README.rdoc SPEC"
-
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem eutils versionator
-
-DESCRIPTION="A modular Ruby webserver interface"
-HOMEPAGE="http://rubyforge.org/projects/rack"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~alpha amd64 ~ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend "virtual/ruby-ssl"
-
-# The gem has automagic dependencies over mongrel, ruby-openid,
-# memcache-client, thin, mongrel and camping; not sure if we should
-# make them dependencies at all. We do add the fcgi dependency because
-# that spec isn't optional.
-ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/fcgi )"
-
-# Block against versions in older slots that also try to install a binary.
-RDEPEND="${RDEPEND} !<dev-ruby/rack-1.1.3-r1:0 !<dev-ruby/rack-1.2.5:1.2"
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${PN}-1.2.1-gentoo.patch
-
- # Avoid tests depending on now randomized hash ordering.
- sed -i -e '/foobarfoo/ s:^:#:' test/spec_response.rb || die
- sed -i -e '/build query strings correctly/,/end/ s:^:#:' test/spec_utils.rb || die
- sed -i -e '/build nested query strings correctly/,/end/ s:^:#:' test/spec_utils.rb || die
-}
-
-each_ruby_test() {
- # Since the Rakefile calls specrb directly rather than loading it, we
- # cannot use it to launch the tests or only the currently-selected
- # RUBY interpreter will be tested.
- ${RUBY} -S bacon -Ilib -w -a \
- -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
- || die "test failed for ${RUBY}"
-}
diff --git a/dev-ruby/rack/rack-1.4.4.ebuild b/dev-ruby/rack/rack-1.4.4.ebuild
deleted file mode 100644
index 923201d555aa..000000000000
--- a/dev-ruby/rack/rack-1.4.4.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rack/rack-1.4.4.ebuild,v 1.5 2013/01/21 14:09:52 ago Exp $
-
-EAPI=5
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_EXTRADOC="ChangeLog KNOWN-ISSUES README.rdoc SPEC"
-
-inherit ruby-fakegem eutils versionator
-
-DESCRIPTION="A modular Ruby webserver interface"
-HOMEPAGE="http://rack.github.com/"
-SRC_URI="mirror://rubyforge/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="$(get_version_component_range 1-2)"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-RUBY_PATCHES=( ${PN}-1.2.1-gentoo.patch ${PN}-1.4.3-tmpdir.patch )
-
-ruby_add_rdepend "virtual/ruby-ssl"
-
-# The gem has automagic dependencies over mongrel, ruby-openid,
-# memcache-client, thin, mongrel and camping; not sure if we should
-# make them dependencies at all. We do add the fcgi dependency because
-# that spec isn't optional.
-ruby_add_bdepend "test? ( dev-ruby/bacon dev-ruby/fcgi )"
-
-# Block against versions in older slots that also try to install a binary.
-RDEPEND="${RDEPEND} !<dev-ruby/rack-1.1.3-r1:0 !<dev-ruby/rack-1.2.5:1.2 !<dev-ruby/rack-1.3.6-r1:1.3"
-
-each_ruby_test() {
- # Since the Rakefile calls specrb directly rather than loading it, we
- # cannot use it to launch the tests or only the currently-selected
- # RUBY interpreter will be tested.
- ${RUBY} -S bacon -Ilib -w -a \
- -q -t '^(?!Rack::Handler|Rack::Adapter|Rack::Session::Memcache|Rack::Server)' \
- || die "test failed for ${RUBY}"
-}