summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-09-05 09:22:59 +0000
committerHans de Graaff <graaff@gentoo.org>2010-09-05 09:22:59 +0000
commit035eeaa5e2ce31eb56891cc77c5e3167061368bd (patch)
tree0abc40020ecab3a58e748f1ef03cb5161f32974b /dev-ruby/rails
parentVersion bump for Rails 2.3.9 (diff)
downloadgentoo-2-035eeaa5e2ce31eb56891cc77c5e3167061368bd.tar.gz
gentoo-2-035eeaa5e2ce31eb56891cc77c5e3167061368bd.tar.bz2
gentoo-2-035eeaa5e2ce31eb56891cc77c5e3167061368bd.zip
Version bump for Rails 2.3.9
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rails')
-rw-r--r--dev-ruby/rails/ChangeLog7
-rw-r--r--dev-ruby/rails/rails-2.3.9.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index 62aca89677d1..cd632fc180ef 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.175 2010/05/31 06:10:03 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.176 2010/09/05 09:22:59 graaff Exp $
+
+*rails-2.3.9 (05 Sep 2010)
+
+ 05 Sep 2010; Hans de Graaff <graaff@gentoo.org> +rails-2.3.9.ebuild:
+ Version bump for Rails 2.3.9
*rails-2.3.8 (31 May 2010)
diff --git a/dev-ruby/rails/rails-2.3.9.ebuild b/dev-ruby/rails/rails-2.3.9.ebuild
new file mode 100644
index 000000000000..8d1e292dfc54
--- /dev/null
+++ b/dev-ruby/rails/rails-2.3.9.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.3.9.ebuild,v 1.1 2010/09/05 09:22:59 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_EXTRAINSTALL="builtin configs doc dispatches environments fresh_rakefile helpers html README"
+RUBY_FAKEGEM_EXTRADOC="README CHANGELOG"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+# gem lacks tests
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-rails-0.15"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.3
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activeresource-${PV}
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ ~dev-ruby/actionpack-${PV}"
+ruby_add_bdepend "doc? ( dev-ruby/redcloth )"
+
+all_ruby_prepare() {
+ sed -i -e '/horo/d' Rakefile || die "Could not remove reference to unavailable documentation template."
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rails rails-${PV}
+
+ if use doc; then
+ pushd doc
+ docinto api
+ dohtml -r *
+ popd
+ fi
+}
+
+pkg_postinst() {
+ elog "To select between slots of rails, use:"
+ elog "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm() {
+ eselect rails update
+}