summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-14 16:47:43 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-14 16:47:43 +0000
commitbca3f40552622bc1ad07fb191fabd48ad571b3d7 (patch)
treeca95bedebf4f476fe90c2cbfcb4a9586af657aeb /dev-ruby/rails
parentAdd some more locales for openoffice (diff)
downloadgentoo-2-bca3f40552622bc1ad07fb191fabd48ad571b3d7.tar.gz
gentoo-2-bca3f40552622bc1ad07fb191fabd48ad571b3d7.tar.bz2
gentoo-2-bca3f40552622bc1ad07fb191fabd48ad571b3d7.zip
Bump to ruby-fakegem. Tests cannot be executed because upstream does not package them.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rails')
-rw-r--r--dev-ruby/rails/ChangeLog11
-rw-r--r--dev-ruby/rails/rails-2.3.5-r1.ebuild79
2 files changed, 88 insertions, 2 deletions
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index 30d4bf076577..1ca897a7d7d2 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/rails
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.165 2009/12/20 09:08:15 a3li Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.166 2010/01/14 16:47:43 flameeyes Exp $
+
+*rails-2.3.5-r1 (14 Jan 2010)
+
+ 14 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +rails-2.3.5-r1.ebuild:
+ Bump to ruby-fakegem. Tests cannot be executed because upstream does not
+ package them.
20 Dec 2009; Alex Legler <a3li@gentoo.org> -rails-2.2.3.ebuild,
-rails-2.3.4.ebuild:
diff --git a/dev-ruby/rails/rails-2.3.5-r1.ebuild b/dev-ruby/rails/rails-2.3.5-r1.ebuild
new file mode 100644
index 000000000000..4a44047707ab
--- /dev/null
+++ b/dev-ruby/rails/rails-2.3.5-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.3.5-r1.ebuild,v 1.1 2010/01/14 16:47:43 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_EXTRAINSTALL="builtin configs dispatches environments helpers html"
+RUBY_FAKEGEM_EXTRADOC="README CHANGELOG"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+# gem lacks tests
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64"
+
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-rails-0.15"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.3
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activeresource-${PV}
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ ~dev-ruby/actionpack-${PV}"
+ruby_add_bdepend doc dev-ruby/redcloth
+ruby_add_bdepend test dev-ruby/mocha
+
+all_ruby_prepare() {
+ sed -i -e '/horo/d' Rakefile || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ # fails for missing template when using the gem distribution
+ #if use doc; then
+ # pushd guides
+ # ruby rails_guides.rb || die "guide generation failed"
+ # popd
+ #fi
+}
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rails rails-${PV}
+
+ if use doc; then
+ #pushd guides/output
+ #docinto guides
+ #dohtml -r *
+ #popd
+
+ pushd doc
+ docinto api
+ dohtml -r *
+ popd
+ fi
+}
+
+pkg_postinst() {
+ elog "To select between slots of rails, use:"
+ elog "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm() {
+ eselect rails update
+}