summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2013-01-25 20:50:24 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2013-01-25 20:50:24 +0000
commite069115ed9d8f966421050225b52c7530b730128 (patch)
treeb0550d6cc5f0f1b0d3ead5e3c11643613c67251a /dev-ruby/rails_autolink/rails_autolink-1.0.9.ebuild
parentAdd menu desktop file and icons, bug #453920 (diff)
downloadgentoo-2-e069115ed9d8f966421050225b52c7530b730128.tar.gz
gentoo-2-e069115ed9d8f966421050225b52c7530b730128.tar.bz2
gentoo-2-e069115ed9d8f966421050225b52c7530b730128.zip
Initial import of rails_autolink from graaff's overlay. This version only supports Ruby 1.9 (as the testsuite fails on 1.8), spots a fix for the testsuite and the schemes, and support doc building.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'dev-ruby/rails_autolink/rails_autolink-1.0.9.ebuild')
-rw-r--r--dev-ruby/rails_autolink/rails_autolink-1.0.9.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/rails_autolink/rails_autolink-1.0.9.ebuild b/dev-ruby/rails_autolink/rails_autolink-1.0.9.ebuild
new file mode 100644
index 000000000000..38fb3223f950
--- /dev/null
+++ b/dev-ruby/rails_autolink/rails_autolink-1.0.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails_autolink/rails_autolink-1.0.9.ebuild,v 1.1 2013/01/25 20:50:24 flameeyes Exp $
+
+EAPI=5
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This is an extraction of the auto_link method from rails."
+HOMEPAGE="http://github.com/tenderlove/rails_autolink"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RUBY_PATCHES=( ${P}-fixes.patch )
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+ruby_add_rdepend ">=dev-ruby/rails-3.1"
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_*.rb || die "tests failed"
+}