summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2010-01-10 23:04:27 +0000
committerAlex Legler <a3li@gentoo.org>2010-01-10 23:04:27 +0000
commit83ae53b63d1e8fa2d7b17565242d24075bde069b (patch)
tree08756cf4c8b090da49d08b388e415ef679b9e536 /dev-ruby/rdoc
parentbackport RTLD_NOLOAD support from 8.0; headers and manpage part (diff)
downloadgentoo-2-83ae53b63d1e8fa2d7b17565242d24075bde069b.tar.gz
gentoo-2-83ae53b63d1e8fa2d7b17565242d24075bde069b.tar.bz2
gentoo-2-83ae53b63d1e8fa2d7b17565242d24075bde069b.zip
Properly install the binaries into /usr/bin, bug 300489 by Andy Kittner
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/rdoc')
-rw-r--r--dev-ruby/rdoc/ChangeLog8
-rw-r--r--dev-ruby/rdoc/rdoc-2.4.3-r1.ebuild (renamed from dev-ruby/rdoc/rdoc-2.4.3.ebuild)4
2 files changed, 9 insertions, 3 deletions
diff --git a/dev-ruby/rdoc/ChangeLog b/dev-ruby/rdoc/ChangeLog
index 2890de2cf4cb..ccf6dad83a9a 100644
--- a/dev-ruby/rdoc/ChangeLog
+++ b/dev-ruby/rdoc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rdoc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdoc/ChangeLog,v 1.19 2010/01/04 23:02:09 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdoc/ChangeLog,v 1.20 2010/01/10 23:04:27 a3li Exp $
+
+*rdoc-2.4.3-r1 (10 Jan 2010)
+
+ 10 Jan 2010; Alex Legler <a3li@gentoo.org> -rdoc-2.4.3.ebuild,
+ +rdoc-2.4.3-r1.ebuild:
+ Properly install the binaries into /usr/bin, bug 300489 by Andy Kittner
04 Jan 2010; Markus Meier <maekke@gentoo.org> rdoc-2.4.3.ebuild:
add ~x86, bug #297041
diff --git a/dev-ruby/rdoc/rdoc-2.4.3.ebuild b/dev-ruby/rdoc/rdoc-2.4.3-r1.ebuild
index d0422ff5fd24..3f9660492963 100644
--- a/dev-ruby/rdoc/rdoc-2.4.3.ebuild
+++ b/dev-ruby/rdoc/rdoc-2.4.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdoc/rdoc-2.4.3.ebuild,v 1.6 2010/01/04 23:02:09 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdoc/rdoc-2.4.3-r1.ebuild,v 1.1 2010/01/10 23:04:27 a3li Exp $
EAPI=2
USE_RUBY="ruby18 ruby19"
@@ -31,7 +31,7 @@ all_ruby_install() {
all_fakegem_install
for bin in rdoc ri; do
- ruby_fakegem_binwrapper $bin $bin-2
+ ruby_fakegem_binwrapper $bin /usr/bin/$bin-2
done
}