summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-24 15:08:11 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-24 15:08:11 +0000
commit0b725249c7b7b866625a613e9ef424bde482d496 (patch)
treee5ee951564934988c1dee5cda001c0ed8b9e2f67 /dev-ruby/right_http_connection
parentMarked ~{sparc{,64},x{64,86}}-solaris (diff)
downloadgentoo-2-0b725249c7b7b866625a613e9ef424bde482d496.tar.gz
gentoo-2-0b725249c7b7b866625a613e9ef424bde482d496.tar.bz2
gentoo-2-0b725249c7b7b866625a613e9ef424bde482d496.zip
Version bump. Run cucumber features for ruby18/ree18 since we don't have it yet for the others and we didn't run anything before.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/right_http_connection')
-rw-r--r--dev-ruby/right_http_connection/ChangeLog9
-rw-r--r--dev-ruby/right_http_connection/right_http_connection-1.3.0.ebuild40
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-ruby/right_http_connection/ChangeLog b/dev-ruby/right_http_connection/ChangeLog
index 8a9e63f8663f..770e70930231 100644
--- a/dev-ruby/right_http_connection/ChangeLog
+++ b/dev-ruby/right_http_connection/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/right_http_connection
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/right_http_connection/ChangeLog,v 1.9 2011/12/05 14:22:42 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/right_http_connection/ChangeLog,v 1.10 2011/12/24 15:08:11 graaff Exp $
+
+*right_http_connection-1.3.0 (24 Dec 2011)
+
+ 24 Dec 2011; Hans de Graaff <graaff@gentoo.org>
+ +right_http_connection-1.3.0.ebuild:
+ Version bump. Run cucumber features for ruby18/ree18 since we don't have it
+ yet for the others and we didn't run anything before.
05 Dec 2011; Naohiro Aota <naota@gentoo.org>
right_http_connection-1.2.4-r1.ebuild:
diff --git a/dev-ruby/right_http_connection/right_http_connection-1.3.0.ebuild b/dev-ruby/right_http_connection/right_http_connection-1.3.0.ebuild
new file mode 100644
index 000000000000..9242f3d0c221
--- /dev/null
+++ b/dev-ruby/right_http_connection/right_http_connection-1.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/right_http_connection/right_http_connection-1.3.0.ebuild,v 1.1 2011/12/24 15:08:11 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18 ruby19 jruby"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+RUBY_FAKEGEM_TASK_TEST="cucumber"
+
+inherit ruby-fakegem
+
+DESCRIPTION="RightScale's robust HTTP/S connection module"
+HOMEPAGE="http://rightscale.rubyforge.org/"
+SRC_URI="https://github.com/rightscale/right_http_connection/tarball/v${PV} -> ${P}.tgz"
+RUBY_S="rightscale-${PN}-*"
+
+LICENSE="as-is" # truly
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+all_ruby_prepare() {
+ rm Gemfile Gemfile.lock || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *ruby19)
+ ;;
+ *jruby)
+ ;;
+ *)
+ each_fakegem_test
+ ;;
+ esac
+}