summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-06-24 05:12:36 +0000
committerHans de Graaff <graaff@gentoo.org>2012-06-24 05:12:36 +0000
commitea28afe41e79445886b4a59827cff01f4c061848 (patch)
tree730c0693fab044c2e04d959e7f0006e9b99348e1 /dev-ruby/right_http_connection
parentVersion bump (bug #421429). Remove old. (diff)
downloadgentoo-2-ea28afe41e79445886b4a59827cff01f4c061848.tar.gz
gentoo-2-ea28afe41e79445886b4a59827cff01f4c061848.tar.bz2
gentoo-2-ea28afe41e79445886b4a59827cff01f4c061848.zip
Call cucumber directly to avoid unneeded dependency on rspec, bug 423217. Add missing cucumber dependency. Avoid bundler dependency. Also restrict tests since ppc/ppc64 do not have cucumber keyworded yet and because the test certificate seem to have expired.
(Portage version: 2.1.10.65/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/right_http_connection')
-rw-r--r--dev-ruby/right_http_connection/ChangeLog9
-rw-r--r--dev-ruby/right_http_connection/right_http_connection-1.3.0.ebuild8
2 files changed, 14 insertions, 3 deletions
diff --git a/dev-ruby/right_http_connection/ChangeLog b/dev-ruby/right_http_connection/ChangeLog
index 16e16af3988a..9f11f422bc99 100644
--- a/dev-ruby/right_http_connection/ChangeLog
+++ b/dev-ruby/right_http_connection/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/right_http_connection
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/right_http_connection/ChangeLog,v 1.11 2012/05/01 18:24:25 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/right_http_connection/ChangeLog,v 1.12 2012/06/24 05:12:36 graaff Exp $
+
+ 24 Jun 2012; Hans de Graaff <graaff@gentoo.org>
+ right_http_connection-1.3.0.ebuild:
+ Call cucumber directly to avoid unneeded dependency on rspec, bug 423217. Add
+ missing cucumber dependency. Avoid bundler dependency. Also restrict tests
+ since ppc/ppc64 do not have cucumber keyworded yet and because the test
+ certificate seem to have expired.
01 May 2012; Raúl Porcel <armin76@gentoo.org>
right_http_connection-1.2.4-r1.ebuild, right_http_connection-1.3.0.ebuild:
diff --git a/dev-ruby/right_http_connection/right_http_connection-1.3.0.ebuild b/dev-ruby/right_http_connection/right_http_connection-1.3.0.ebuild
index 406c65c900b4..1d2689584e6d 100644
--- a/dev-ruby/right_http_connection/right_http_connection-1.3.0.ebuild
+++ b/dev-ruby/right_http_connection/right_http_connection-1.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/right_http_connection/right_http_connection-1.3.0.ebuild,v 1.2 2012/05/01 18:24:25 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/right_http_connection/right_http_connection-1.3.0.ebuild,v 1.3 2012/06/24 05:12:36 graaff Exp $
EAPI=4
@@ -23,8 +23,12 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE=""
+RESTRICT="test"
+#USE_RUBY="ruby19 ree18" ruby_add_bdepend "test? ( dev-util/cucumber )"
+
all_ruby_prepare() {
rm Gemfile Gemfile.lock || die
+ sed -i -e '/bundler/ s:^:#:' features/support/env.rb || die
}
each_ruby_test() {
@@ -34,7 +38,7 @@ each_ruby_test() {
*jruby)
;;
*)
- each_fakegem_test
+ ${RUBY} -S cucumber features || die
;;
esac
}